MySQL config page issues (Jarvis)

I was setting up a new RPi 2 with a fresh install.

I installed the latest image and before I did anything else I updated OSMC to the latest version.

After that I decided to set up a MySQL Video DB but a few issues showed up.

The “landing” page provides youi the name MyVideos by default so I didn’t modify that, next was to enter the MySQL DB server IP.

First weird thing to happen is that an unknown IP showed up while I was expecting an empty field (as shown before trying to edit)

Then I wanted to enter the port number but instead of finding an empty field the IP I just typed in. I could not delete, but started typing the port number and it worked just like there was nothing in it.

Typed in the user and password and so I thought that it was all done. But when I wanted to exit I got a message saying that the data was incomplete so if I left the changes would not take effect.

It happened to be that the DB name “MyVideos” was not actually a set parameter, so I had to edit the value and type “MyVideos” in the empty field.

It can all be seen in the hidden youtube video I just made: watch?v=OCNOJPPKJBs

After I finished all that I noticed too that reentering the network config produced the following overlay issue: watch?v=IZRaKBOTzvg
I could not replicate it in another fresh installation.

But there is an issue that also bothers me with copying the advancedsettings and sources xml files from an already configured OSMC to a fresh installed one. After successfuly configuring the sources, content types and MySQL VideoDB I backed up the advancedsettings.xml and sources.xml files, then I did a fresh install and update in another microsd, copied the xml files to the corresponding userdata folder in the freshly installed osmc and what I get is the sources and the correct parameters under MySQL VideoDB config, but the sources don’t have a content type configured. The weird thing is that on “another new” fresh install that I was doing recording all the process to show you all these problems it worked like a charm.

So I can’t really find the problem why this is happening, but it does.

I am sorry if I my explanation is not very clear but I can’t think clearly as I have a big flu.

Make any questions I can record videos or provide you any info you want.

I believe that’s a sample text field, so you have an idea of what format ot enter the IP in.

Can you explain this in a bit more detail?

CC @Karnage

Get well soon and let us know if you still experience issues


You can see what happens on the first video. I recorded it this afternoon just to show you what happens.

If it was a sample text field maybe it should look more like a typical local IP like 192.168.x.x but it shows a “random IP” like on the video which is xxx.114.115.34 (can’t remember the first 3 digits and can’t read them on the video.) I say random because I did three fresh installations to test some stuff and the IP shown there was different each time.

About the port issue, if I typed my server IP in the form when I press enter on the port input to input it and the IP I just typed appears there. The same that I typed on the IP input.

And as I said I can’t delete it, but as I type the first “3” from the 3306 port the IP goes away and the 3 appears and so I can type just like in a normal input.

I think it’s also important to defalult “MyVideos” on the name input as it’s confusing to see it set on the “landing network page” but if you try to edit there is no value.

Any idea on the advancedsettings.xml and sources.xml files setting the sources and mysql params but not applying the content params of each source?

The MySQL fields dont have placeholder IP addresses. The only thing that goes in there is what is read from the advancedsettings.xml file.

As I said it’s a clean installation so there is no pre-configured advancedsettings.xml file. Did you watch the video? There is nothing else I did before apart from a manual IP config.

I’ll wait for the Jarvis image to come out and I’ll test then to discard an upgrade problem from the previous version if you like.

I’m sorry to bring this back but since you guys uploaded the last image file I’ve done a clean install just for the sake of testing.

Again, the video database name seems to be MyVideos but unless you edit it you can’t save the config. It’s confusing, it would be better if you didn’t provide the “MyVideos” text or if you do, make it the default text in the input box.

But the weirdest thing is still with the port input. It still defaults a random IP. You can test it easy as I did a clean install just to check that. Since the license problem that prevented the wizzard from completing I only connected the PI to the internet to be able to finish the wizzard, and apart from that no internet connection was provided during the MySql Video configuration. My device is a RPi 2.

If this is a Kodi issue let me know and I’ll try to tell them so that they know the issue is there.

This is not an issue that really bothers me, I’m just letting you know as it’s present.