MySQL-Database not used after updating from 2015.08-1 to 2015-09-2

Hi, the MySQL-Database is not used after updating from 2015.08-1 to 2015-09-2.

Device: vero
Installation media: SDcard
Connection: Wired
Power Supply Type: Included Vero Power Supply
Peripherals: -
Storage Device: Ubuntu-NAS using NFS and running the SQL-Server
OSMC version: 2015.09-2
Audio/Video Output: HDMI
Overclocked: default Image Setting

I reinstalled the 2015.08-1 Image and copied my advancedsettings.xml:


-> Databases are working!

After that I updated via “my OSMC” and the databases are not shown, again.
Did something change? Are there new settings I have to adjust? What do I have to change?

Besides the Vero, there are a Raspberry Pi and Windows PCs running Kodi using the SQL-Database without problems in my Home-Network.

Exact same problem… I do notice the new update has MySQL options in settings… Maybe we have to set them instead of using AdvancedSettings.xml Anyone???

I found the MySQL-settings:

Looks like it is a copy from the advancedsettings.xml.
Maybe “Name” is causing the problem?

When I did a fresh install it was crawling through the SQL settings you show above. So I gave up and FTP’d over an AdvaNCEDSettings.XML…

“MyVideos” is not the same as “kodi_video” so maybe this is the problem?

If it helps, these are my databases:

Can you try to change the names in the MySQL settings page to MyVideos93 and MyMusic52 and then reboot?

I’ve tried it, but it didn’t not work.

What is currently in your advancedsettings.xml?

(You can upload that along with your Kodi logs using the LogUploader module in MyOSMC.)

I have the exact same problem after upgrading from july version to 2015.09-3
I did try to rename the mysql settings on the vero from MyVideos to MyVideos93 but no luck.
My advancedsettings.xml is still present.
My MySQL database is running on a synology nas.

Is there anyway to make it work again?
My Vero is useless to me when this is not functioning

Enable “wait for network” in MyOSMC>Network settings then reboot, if it still fails check the osmc log file for errors. Do NOT add the number to the end of the name in advancedsettings.xml, this is the database version and changes when versions change


Thanks for the quick reply.
It did however not solve the issue.
I will try to make a fresh installation tomorrow and see how that turns out.

Where’s the log???

I tried to edit the mysql settings from the menu on the vero but the changes could not be saved and i could not go back to the home screen when i was in the mysql settings.
I then took a look on the log and somehow my advancedsettings.xml was now somewhat empty.

As shown below the host, user and port where missing.
I then uploaded a backup of my advancedsettings.xml and rebooted and then things where back to normal.

15:35:28 T:1957781504 NOTICE: Contents of special://profile/advancedsettings.xml are…
<?xml version="1.0" encoding="utf-8" ?>



We are still improving MySQL configuration from the GUI


Today I switched on my TV and the Databases were loaded. I don’t know why. I changed nothing, except, I renamed the names back to MyVideos a few Days ago.
I don’t have all log Data, only the Kodi.log:
(The automatic upload from MyOSMC didn’t worked. Something like “log to long…”.)

After that I rebooted from Main Menu and the Databases were gone.
Here is the kodi.log after rebooting:

If the Databases will appear again, I can upload the full logs here.
(Now I know that I can save them to SD-Card if automatic upload does not work…)
Maybe the Databases need some Hours to load after rebooting, I will try to test that…

Definitely sounds like a network issue, are you sure “wait for network” is checked in MyOSMC>Networking ???

That solved the Problem.
If that setting is checked, the Databases are loading, after rebooting.
If it’s not checked, and I reboot the Databases are not loading.
Thanks Dilligaf!