MySQL settings not working

Hello, i would want to associate the mysql accounts to profiles

i have this advancedsettings in profile directory but it does not work :

<advancedsettings>
  <videodatabase>
    <type>mysql</type>
    <host>192.168.0.XX</host>
    <port>3307</port>
    <user>kodi</user>
    <pass>xxxxxxx</pass>
    <name>kidsVideo</name>
  </videodatabase>
</advancedsettings>

is a setting wrong ? i read advancedsettings is supported at profile level (parents and kids profile )
(i checked in log the advancedsettings is read but then nothing happens)
(i managed to make an advancedsettings work but without the instruction)

Hi,

Try changing the port to:

<port>3306</port>

Thanks Tom.

Hey Tom,

thanks for your help, but this is the right port confirmed and working on an other omsc (without the name directive and setting at userdata root level)

Hi,

I’ve moved you post and subsequent replies, so we can investigate this issue. Please provide debugging logs:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Its odd that 3306 doesn’t work, as this is the standard mysql port?

Thanks Tom.

Hey,

this is a second install of mysql on my NAS i guess 3306 is reserved for the older installation,

while preparing logs for you i finaly saw there was a database connection issue i didn’t see on ssh because i used grep sql etc …

so i remembered i changed the mysql user password ! so i corrected it and it works ! perfect ! thank you for your guidance :slight_smile: :slight_smile:

then i would just say you may add to your howto that you can set advancedsettings at profile level ! i think there is a lack of information on this and that it is usefull when you use a profil for kids ! !!

thanks this is great :slight_smile:

Hi,

Glad to hear its working now.

Thanks Tom.

1 Like