MythTV add-on enabled, but no TV or Radio menus on Raspberry Pi

I’m trying to use a raspberry pi as a frontend to my MythTV backend. I’m new to OSMC, but not new to Linux.

I installed the MythTV Add-on, configured it with the address of my backend, and enabled it but I couldn’t find any way to use the add-on.

Eventually, I installed the Demo PVR add-on, rebooted, and got the TV and Radio items in the top-level menu, I could enter them and find the demo items. at this point, both the MythTV and Demo PVRs were enabled. I disabled the Demo PVR, the TV and Radio menus disappeared. I disabled the MythTV PVR and got a “searching for PVRs” pop-up, then a warning that there were no PVRs. I re-enabled the MythTV PVR and rebooted, still no TV and Radio menus.

OSMC seems to believe MythTV PVR is providing PVR services, but the menu items are not there.
I noticed that the Run item in the MythTV PVR information page was greyed out, screenshot attached.

Logfile from when I booted, went to the MythTV PVR configuration page, disabled it, then enabled it:
What have I done wrong? Thanks in advance.

I’m currently experiencing what I guess is the same issue (no TV menu despite MythTV plugin being activated, haven’t tried enabling the demo PVR yet). Has anybody looked at that yet? Any pointers in which direction I could search myself?

If you change the theme to the standard KODI theme you will get the menus you are looking for.