Names of movies/shows in Kodi/OSMC

Hello support,

I spent couple days to make names of movies/shows correct in the MediaElch.
But names were not updated when I ran update library on the RPi2 (OSMC OS) :worried:

Exmpl: Movie “10 Rules for Winning Her Heart”
CZ name is “10 pravidel jak sbalit holku”

The MediaElch created these two files:

  • 10 pravidel jak sbalit holku (2014).nfo - contained correct name 10 pravidel jak sbalit holku"
  • movie.xml - contained “wrong” tags
    LocalTitle 10 Rules /LocalTitle
    OriginalTitle 10 Rules /OriginalTitle
    Should I removed the “movie.xml” files from whole NAS?

Also, there are couple files, which I already removed from NAS, so I hoped that when I run “library update” the will dispersed from Kodi, but they are still there :frowning:
Any idea how to force Kodi to forget removed files and also read the “.nfo” files correctly?

Thank you.

To forget the movies I believe you have to use “clean library” from the settings menu.
To use the information from the .nfo files instead of what online scrapers provice you would change it in the content settings to use local files instead of a scraper.

Ok, I will try “clean library”…

Yes, I set the RPi2 to “local nfo files” when I was adding movies/shows…

OKi,… I have done…

Removed all movie.xml and serie.xml files from whole NAS…
Cleaned library: System > Video > Clean library
Ran update library…

The removed files are not in the list anymore, but Czech names written in the MedieElch (which are present in the tvshow.nfo or .nfo are still not show in the Kodi on the RPi2

Cleaned library again: System > Video > Clean library
RPi2 rebooted
Running update library now again…

Not sure if it will help…
Or how to force RPi2 read the local nfo files? Thank you.

So, update library done, but names of movies/shows are still “wrong”…
No idea where RPi2 took them :confused:

I do have setup Movies/Show folders like this:

“Local information only”

In Movie folder is one nfo only, named same as movie file (example):
10 pravidel jak sbalit holku (2014).avi
10 pravidel jak sbalit holku (2014).nfo

nfo contain:
title 10 pravidel jak sbalit holku /title
originaltitle 10 pravidel jak sbalit holku /originaltitle
but OSMC still showing name: 10 rules

Another example:
Warriors 700 (shoft movie about network):

nfo contains:
title Jak funguje sit /title
originaltitle Warriors 700 /originaltitle
But OSCM show “empty title”, just empty line in the OSMC list

Same for Shows (example):
12 Monkeys (2015)
Sub-folder: Season 1
tvshow.nfo contain:
title 12 Opic /title

but OSMC still showing: 12 Monkeys

But the parts are:

the nfo contains:
title Splinter /title
showtitle 12 Monkeys /showtitle

So, do I need to update all nfo files for each part?
But why movies still show incorrect name? there is only one nfo file :confused:

Any idea? Thank you.

Screenshot does not appear that you are selecting “Local Information Only” as scraper.

That picture is from Google, I did not took picture of my TV.

But yes, on my RPi2 home I selected the “Local Information Only”.
Also those two below I do have selected as well.

You are probably better to ask Kodi specific questions in the Kodi forums for a faster and more specific answer. It’s not immediately obvious what the problem is but I can’t imagine that it’s something specific to OSMC.

OK thanks…
Asked here: Incorrect names of movies/shows in Kodi

So, I spent another hours by renaming files, but again … it did NOT help
I cleaned library and re-scan library… nothing

Great example is the: Warriors 700
This is contained of warriors-700-de-VBR.nfo file:

<?xml version='1.0' encoding='utf-8'?> title>Jak funguje sit originaltitle>Warriors 700 sorttitle> set> rating>0 year>2002 top250>0 votes>0 outline> plot> tagline> certification/> mpaa>Rated playcount>0 watched>false filenameandpath/> trailer> id> tmdbid> credits> director> thumb preview=""> fileinfo> streamdetails> video/> subtitle> language> file> /subtitle> /streamdetails> /fileinfo> /movie>

Ehm, not possible to insert nfo correct. so removed the starting <

Kodi setup to:
This directory contains: (Movies)
Choose a Scraper: Local information only
Movies are in separate folders … : checked
Scan recursively: checked

But again, once scan finished, this “movie” has no tittle, just empty line in the Movie list
And for most of the other movies, where nfo file contain Czech name, still engl. name of movie is shown.

Is really Kodi taking name of the movie from the nfo file? It does not seems so
How can I FORCE it to really read what is in the nfo files?
Thank you.

OK, so now I´m completely lost :sniffle: :rolleyes:

I cleaned library… then I removed both folders (Movies and Shows), so there were no movies at all in the Kodi :angel:

Then I added Show and Movie folders again and re-scan them, but again some of Names in the Kodi are in Czech, some still in Engl. :huh: :s

How/Where Kodi is taking these names from???

Example: Pirates…
Kodi is displaying: Pirates of the Caribbean The Curse of the Black Pearl
Folder name: Piráti z Karibiku Prokletí Černé perly (2003)
File name: Piráti z Karibiku Prokletí Černé perly (2003).avi

File: movie.nfo

[quote]?xml version=“1.0” encoding=“UTF-8” standalone=“yes”?>
!-- created on 2015-12-12 22:52:44 - tinyMediaManager 2.6.9 →
title>Pirates of the Caribbean The Curse of the Black Pearl/title>
outline>Blacksmith Will Turner teams up with eccentric pirate Captain Jack Sparrow to save his love, the governor’s daughter, from Jack’s former pirate allies, who are now undead./outline>
mpaa>US:not rated/mpaa>
certification>US:not rated/certification>
value xsi:type=“xs:string” xmlns:xs=“XML Schema” xmlns:xsi=“”>/value>
studio>Walt Disney Pictures/studio>
filenameandpath xmlns:xs=“XML Schema” xmlns:xsi=“”/>

File: Piráti z Karibiku Prokletí Černé perly (2003).nfo

So, how can I force Kodi to display correctly “Piráti z Karibiku Prokletí Černé perly” and not the Engl name “Pirates of the Caribbean The Curse of the Black Pearl” ??
I´m really desperate now, I renamed all files on whole NAS 2 times already and I´m did not move forward a bit :s :-/ :frowning:
Thank you.[/quote]

Hooray, it seems it is fixed now…

I have done: clean library > check for update in library > clean library > check for update in library
And voila… movies have Czech names and names are same as in the MediaElch (I setup there).

so, seems like the double clean up fix this :confused:

I had the same problem but found another solution that seems “the right one”, at least for me. Although this is an old thread, I left it here for the record.

Look for “My addons” in Kodi configuration and follow this route (I’m translating from Spanish, so the options could be different):

My Addons -> Information Providers -> Movie Information -> The Movie Database -> Configuration

There you will find an option to select your favorite language for the titles. I use “The Movie Database”, so this works for me. But if you use a different provider, I bet they have a similar option.