NAS and homeplug video hanging

This isn’t a specific OSMC issue, but I’m using OSMC with my RPi (v2, ethernet only). Latest update, though has been happening since OSMC was installed (can’t remember exactly if I ever had it with RaspBMC, I think I did, but not from day 1).

I stream video from a NAS which is another part of the house connected to the network via a homeplug. Samba.
To add to the possibility of unreliability, the NAS is in the extension that has a separate consumer unit.
The RPi is directly connected to the router in the main house.
So no, not ideal, and I’m looking into ways of having the NAS in the main house.

Anyway, it often happens when playing back the video pauses. After a while (from 10 seconds up to >2min but not sure when because I’ve rebooted the Pi), one of a few things occur:
Either the video resumes from where it was
The video fastforwards to where it would have been had it been playing, then resumes
Sometimes, if subtitles are on, the subtitles continue to update even when the video pauses.
Sometimes, kodi returns to the menu.

In all cases, the remote (logitech harmony controlling pi via usb IR dongle) appears to be unresponsive, though after repeated pressing os stop, kodi returns to the menu. After rreturning to the menu, we can resume playback which often is at the point of hanging, sometimes earlier.

Happens on low bitrate, high bitrate, various file formats.
It never happens if I’m streaming the same video from a memory stick in the RPi direct.
I only see it in the evenings, though we don’t do it in the day very often. My main PC is off, only things connected are Humax box, our phones and a printer. I believe for the most part these devices are not up to much (no automatic updates for instance that could cause a traffic issue)

It is sometimes intermittent, won’t happen for a few weeks, but then we get it several times per hour over a few weeks (until I transfer the file to USB for direct playback!)

I understand that the obvious solution is to move the NAS, ethernet directly to the router.

In the meantime I would like to understand if KODI/Pi buffers video data? If not is it possible?
And also, would there be anything in any logs that could help me understand the issue?

Sorry for the long post :confused:

Pay particular attention the the Kodi Krypton changes at section 3.


I had exactly the same issue following the Kodi v17 upgrade and through troubleshooting discovered my powerline adapters sync speed slowly decreases over time down to approx 30Mb/s. I moved my NAS to be on the same gigabit LAN as Osmc and problem solved.

Reading the wiki I probably could have solved the issue by increasing the cache.

Thanks @ActionA, this looks like it could be just the thing, I will give it a go (and report back in a few weeks if I remember!)

I do have a backup plan to move the NAS into the cupboard under the stairs, but will need to drill holes for the power and ethernet, so any improvement with the current setup will be of help.

OK, 3 months in after the changes. I haven’t used the Pi a great deal, but from what I have done, things have been very good. There was one time when the video froze, but pressing ‘stop’ dumped me back to the OSMC menu (which is better than past experience when the control was unresponsive). Overall though it’s very positive :slight_smile:
Thank you