NAS drive for Vero 4k not accessible

Something strange happened… the Drive is called “My Book”, but suddenly the drive seems to have renamed to “My Book_” (that’s an underscore).

See the screenshot. That messed up all the references so the Vero isn’t finding the movie… I tried to cd into the “My Book_” directory, but just says “Permission Denied”.

How do I fix this? I would just try deleting the “My Book_” directory and then “mv My\ Book_ My\ Book”, but I don’t want to mess up the filesystem anymore than it is.

Thoughts?
image

That usually happens if the drive is quickly disconnected/reconnected. Rebooting the Vero should fix it. But you should look into why it was disconnected. I’m assuming that you use fstab to mount. You could try using autofs as it’s more tolerant of disconnects.

Tried to reboot, but still it comes up as “My Book_” Then I did a shutdown, unplugged it, plugged it back it. That did the trick! Now all the content is back on “My Book” and when it scanned it picked up my latest movies I added.

Thanks for the tip!

Well poop. That seemed to work for a while but we had some recent power glitches here and now it’s back to using “My Book_”. I tried rebooting and shutting down, but it keeps mounting back to “My Book_”.

Now I can have it re-scan everything so it finds the new files and hopefully removes the duplicates, but I wish I didn’t have to. I don’t really know anything about using fstab to moung @bmillham - maybe you can enlighten me? I just have it plugged in the USB port and it mounts.

I would suggest to unmount/safely remove the drive in Kodi and unplug it from the Vero. Reboot and then plug it back in. You can manually make a mount via fstab by connecting via ssh and then adding an entry for your drive to fstab via uuid as shown [here] but it really shouldn’t be needed.

Just a side note, and I would only suggest doing this if you decided to manually make a mount in another folder, not to move it for the underscore thing, but you can change a file path without dumping your library as shown in the following guide…

If it keeps unmounting/remounting then it sounds to me like you have a failing drive (or maybe the drives power supply).

Please show us what your fstab looks like. Also paste the output of mount (when the drive is connected). Once I see that we can start troubleshooting this. We’ll get it sorted for you!