NAS nightmares

Hi, I’ve had my NAS set up and nicely working for over two years. Went on holiday the other day and my virgin media Hub went a bit strange and changed its WiFi password while I was away, possibly a firmware update or something, seems to have happened to some other customers too. Anyway, I’m ethernet connected the Vero box and NAS which is an WD my cloud. However Kodi can’t see the NAS anymore, all old links don’t connect. Tried factory reset on the router but didn’t help. Is there anything I should try to let the Vero box see it again?

Kind regards

Have you assigned static IP Addresses to the NAS in your router? If not have you cross check the current IP address of the NAS is identical to before?

1 Like

Hi all kodi was crashing whenever I tried to add an NFS so I reinstalled it. However Kodi cant see my NAS, any advice please? I have a mycloud NAS and vero 4k+ both connected by ethernet. Windows sees the public share fine but nothing comes up when searching with kodi. Not been able to use my vero box for months now, very sad its turning useless unless i can fix this.

Is Windows using NFS or SMB to access the share? Have you enable NFS on the respective share?
Anyway SMB might be easier, but SMB browsing is not possible on the Vero and you just would need to add it manually via smb://server/share.

If you want a long term stable solution you might want to look into fstab/autofs Mounting

Wow thanks, after 4 attempts autofs worked. Cool that I should have more throughput as well. The drive shows as part of the root file system. Do you think it would be good to make a little UI utility to do this as it seems very valuable?

Kind regards

That surely would be great but so far no one had enough spare time to do that in a reliable way for all technologies for integration into OSMC/Kodi.