Need help setting the correct aspect ratio

I just installed OSMC on a Raspberry Pi 2. The ratio on my TV is 1280 x 720. However, when in the OSMC screen, the date/time and power button is partially off the screen. I found a Pi Configuration page online and I tried tweaking the settings in the config.txt file, but I’m not really sure what is what and ended up screwing everything all up. I’ll have to reinstall OSMC to get the it working again. No big deal, but I need to know what settings to change so everything fits on the screen properly.

Any suggestions will be helpful.

Thank you.


If you can get to the OSMC settings module from the OSMC menue, then you can get the system to save and use the information from the edid data from the TV. I don’t have my system on Pi to hand, so cannot focus it better (but have myself used it successfully)

later: The settings you want are under Display (in the OSMC Settings),
store_edid, and ignore_edid

Set whatever resolution your TV likes then go down to Video calibration… to tell Kodi how big to make the viewable area.

The correct solution is to disable overscan on your TV. Parts of the user interface being off the screen is nothing to do with what resolution you’re in, but the fact that your TV is overscanning.

Most modern TV’s allow you to do this on a per-input basis. Look for a screen size setting in the TV menu that says something like “screen fit”, “just fit”, “1:1 pixel” etc.

Thank you to all who replied.

I finally figured out how to use the Video Calibration. When I first stood up OSMC, I looked at Video Calibration, but wasn’t really sure what I needed to do. The screen was just blank. Since one of the suggestions was to use adjust the settings using the Video Celebration, I decided to take a second look. I finally figured out that there are lines in the upper left and lower right corners. The screen is now properly sized.

Thank you for your help.


Glad that worked for you.