Need help w/ sound bar/picking new media box

So I have a Rpi2 (A) right now, absolutely pushed to the limits over clocking it and it actually works pretty decently still, but, I just bought a new sound bar (Yamaha YAS-105) for the room the Pi is in which doesn’t support DTS, just DD (AC3) so I logically tried to turn on the mixer which would mix DTS down but the video becomes horribly choppy, as does the sound, the DD light starts flickering so it does receive 5.1 but its just choppy. If I switch off passthrough at that point I do get sound out of my soundbar, it seem so be amplified stereo with woofer support but none of the lights on my soundbar are on, kind of strange but whatever. I can normally watch whatever I want tot watch then but the sound is not great.

It has 0 problems playing DD 5.1, the light goes on on my sound bar, no problems.

I have my Pi set up through HDMI, so sound passes through my TV (LG 42LV4500-ZC) and then connected the digital out/in from my TV to the soundbar.

Unless someone knows a tweak to solve this I’m pretty sure I’m stuck and need to buy a new device, but which one to get. Obviously people are going to say Vero 2 since, you guys sell that and I will buy one if it meets my requirements.

I mostly play x264 8-bit but sound wise anything from AC3 to FLAC, 5.1 to 7.1, DTS, TrueHD (or whatever that’s called), and anything in between.
Ideal the box would be able to play H264 10-bit smoothly but I know thats a lot to ask for.
Spending limit would be around what you’d pay for a Pi3 kit/Vero2 something like that.

Unless someone knows how I could fix this without having to switch boxes, its old but it works perfectly fine in ultimate overclock mode lol.

Pi2 shouldn’t have a problem with AC3 transcode.
Make sure you have the settings setup correctly.

You want omxplayer to be disabled and MMAL enabled in video/acceleration settings.
You want number of channels set to 2.0 (note: that still allows 5.1 audio in the compressed stream)
Output configuration: Oprimized
Enable Passthrough: On
AC3 capable receiver: On

  • Enable AC3 transcoding: On
    E-AC3 capable receiver: Off
    DTS capable receiver: Off
    Audio DSP processing: Off

There is no hardware decode for 10-bit H264 from any platform, so that requires a powerful CPU to handle it in software. Which basically means an x86 PC.

Nope not working.

Got had it all set up like you suggested to begin with but MMAL not as default, not sure it it is now either.

the sound starts about 10 seconds later and it turns on and off every second or so while it freezes up. The little DD5.1 light starts tripping as well because it receives, then it doesn’t, then it receives again so its lighting up on and off.

I’m using Rapier (tried switching to OSMC as well, no difference in play speed) so I’m not sure if I got the right video acceleration setting.
I went to video then “allow video acceleration: OMXplayer” turned that off.
Left the same one for MMAL turned on.
I don’t know if i’m in the right area even though, maybe its still using OMX.
I also dropped the gui refresh rate while playing to 5fps instead of 10 hoping it would improve some but nothing.

By the way why turn of the DSP? I didn’t have it turned on since I didn’t even know it existed (couldn’t find a plugin either) but my sound bar supports DSP…

As for the 10-bit h264, I know that it’s software encoding but I slowly see CPU’s starting to handle it a bit on Benchmarks of new boxes here and there so it never hurts to ask again ;).
Still annoying because pretty much all Anime is in Hi10P {-.-’}.

Extra info
GUI running at 720p
OC settings:
Arm_freq = 1060
sdram_freq = 500
arm_freq= 500
init_turbo = 60
over_voltage = 6
sdram_over_voltage = 4
Force turbo = off

Audio DSP is broken in Jarvis. Best to leave it off. DSP is done independently of the receiving device, so support doesn’t need to exist for the receiver, it just needs to accept the audio.

Ok thanks Sam.

I’ve been checking though, I always confuse the Rpi models because they label them as A B B+ etc.I think this is actually an Rpi A (frankly i’ve had this for a while so confusion kicking in), since i’m pretty sure this doesn’t have a 900mhz ARM Cortex else I would have had my OC higher.
It says BCM 2708 though, which it would on a Rpi as well so I seriously don’t know lol.

2708 == Pi 1.

Yeah I figured but some people mention it shows up as 2708 on their Pi 2 after a quick google.

Either way I got it to work, sort of, I forgot to reboot after all my settings lol.

What I get now is it skips in the beginning, then slowly smooths out and is in full DD5.1 with MINOR (like really minor) glitching every now and then.

Is there a way to let it buffer a bit, even if its just double the buffer it does now?

Edit:
Small update on that, I watched one of the biggest DTS movies I had just now Star Wars, it started skipping a bit and morphing the sound during the well known yellow text scrolling, then it buffered, after that 0 problems for 26 min of watching. I rewinded it to the beginning, everything played smoothly including the scrolling text.

Also tried a DTS E (whatever that is) movie, some minor glitching at startup, then no issues playing.

The only thing that loads slowly are external subtitles for some reason.

So, I think the buffer needs to be increased, then its problem solved :slight_smile:

Edit:
Changed advancedsettings.xml to

<advancedsettings>
  <network>
     <buffermode>1</buffermode>
     <cachemembuffersize>31457280</cachemembuffersize>
     <readbufferfactor>2</readbufferfactor>
  </network>
</advancedsettings>

And it’s even worse then when I started, no sound for the first minute and a half then choppy, its just horrible.

Edit: removed the advancedsettings.xml all together, rebooted, still as horrible as it used to be :crying_cat_face:

Whether you have a Pi1 or Pi2/Pi3 is pretty important.
Pi1 does not have the CPU power for AC3 transcode.

It’s fairly obvious. Look at the top of the Pi board near the GPIO header.
If it says “Raspberry Pi 2” it is a Pi 2.
If it says “Raspberry Pi 3” it is a Pi 3.
Otherwise it is a Pi 1 and AC3 transcode is not going to work.

Nope it’s a Pi 1.
I’ve been talking to Sam already, going to get a temp Pi 3 replacement (they’re on sale here and you guys aren’t shipping atm :stuck_out_tongue: ) until the Vero 3 shows up.

One issue i’m dealing with now though - you always fix one thing and break something else - I spoke with Sam about it already, my Pi’s internet just plain dropped all of a sudden, haven’t had a response from him yet but how do you generate a log locally because I have no SSH access or anything, it just says Eth0: (not connected) but connection is set to Linked.

The sound connection is the least of my worries now, I have no media box all weekend haha.

I’m not aware of any issues with the latest OSMC update impacting network connectivity. Without knowing how you have configured the network connection (DHCP or static) etc, it is hard to speculate. Also keep in mind that Kodi’s network status information is not completely accurate, as it only polls the network periodically and only uses one domain to evaluate Internet connectivity.

You can login to the command line, run grab-logs and copy the logs to the fat32 partition and pull them from a PC. This is covered in the Wiki.

Static configuration, DNS servers are usually OpenNIC and are usually the same on other devices that do still have connections, router is dd-wrt flashed, I can get network connection between my tablet and my PC, I can not between my Pi and my PC (NFS doesn’t work, SSH doesn’t work).
It never stopped working before, I switched DNSes around, tried Anycast DNSes, google DNSes none of them help but that wouldn’t impact LAN anyway, which stopped working.
The static IP shows up as an active client in DD-WRT, it doesn’t have many active packages though, 50 max but usually 0-1.
Trying to play anything results in nothing, trying to SSH in results in “Network Error: The connection timed out.”

I didn’t really change anything that I didn’t mention in my posts, I removed the advancedsettings.xml again.
The only thing I can remember doing is setting a password for root, I wanted to set one for a user but forgot I was in root while SSHing and just did passwd “pass” and it seemed to accept it.
Other then that I changed nothing.
My SD to USB thumb drive broke down as well so thats great, i have no idea how to retrieve the logs. Nor how to fully reinstall (which would be my last option).

That does require a LAN which it doesn’t seem to have, because my SD to USB stick died.

It seems we just can’t be of any assistance here.

I’m trying to find an old device that supports SD cards right now, see if I can get it some way.

Ok i’ve been looking everywhere for the logs but where does it store them after generating them?
I can’t seem to find them…

Did you check the Wiki?

Sam

I did, couldn’t find it, else i wouldn’t ask.

On /boot which is the first partition of the SD Card.
osmc@osmc:~$ grab-logs --help
usage: grab-logs [-h] [-A] [-T FILENAME] [-C] [-P] [-I] [-p] [-v] [-k] [-r]
[-s] [-f] [-O] [-o] [-a] [-J] [-l] [-i] [-d] [-K] [-m] [-D]
[-b] [-X]

Uploads vital logs to http://paste.osmc.io. If the network is unavailable,
logs are copied to the SD Card.

optional arguments:
-h, --help show this help message and exit
-A, --all Include all logs
-T FILENAME Override default name and location of temporary log file
-C, --copy Copy logs to /boot (SD Card)
-P, --print Print logs to screen (no upload or copy)
-I, --systeminfo System Information
-p, --piconfig Pi config.txt
-v, --advset advancedsettings.xml
-k, --keyboard keyboard.xml
-r, --remote remote.xml
-s, --sources sources.xml
-f, --fstab fstab file
-O, --packages OSMC Packages
-o, --othpack All Other Packages
-a, --apt APT term.log, history.log, sources.list, apt.conf.d,
preferences.d
-J, --sysjrn System Journal
-l, --lirc lirc.conf file
-i, --initd init.d directory
-d, --systemd systemd directory
-K, --kernel Kernel Message Log
-m, --memory System Memory (total & available)
-D, --disk Diskspace (total & available)
-b, --boot Contents of /boot/
-X, --kodi, --xbmc Kodi log files (includes log from previous boot)

What are they called in /boot because I can’t seem to find them.
It said can’t upload copying to /boot (unable to verify) but if I list the files I don’t see anything resembling a log of sorts.

osmc@osmc:~$ grab-logs -C -A
Logs copied to /boot/uploadlog.txt on the SD card FAT partition

osmc@osmc:~$ ls -lah /boot/upload*
-rwxr-xr-x 1 root root 24M Sep 20 18:10 /boot/uploadlog.txt
1 Like

Finally, the log (4MB):
https://mega.nz/#!YIxhSQIZ!CY82bkJyx4hBc43v86hl3daAhElmg4uU2j7twXL4klU