Need help when settings to enable Dolby Atmos

Hi there,

I have the Samsung HW-Q90R sound bar and Samsung Q8DN television. I’ve connected the Vero4K+ directly to the HDMI 1 input on the soundbar, and connected the TV to the soundbar through HDMI ARC.

My issue is that I can’t get my soundbar to display “Atmos” in its display window, which I believe means it is indeed not encoding in Atmos. Instead it says “Surround”, which means it upscales to 7.1 or whichever. When I go to Netflix, I have the option to activate Digital Dolby+. But doesn’t seem like it does anything. Still won’t say Dolby Atmos in display of the soundbar.

When I play a file directly off Vero4K with an Atmos-track, it also says “Surround” and not Atmos. I have enabled “allow passthrough”. Don’t know if that is supposed to be on or not with Vero4k connected straight to soundbar? I struggle mildly to find out what passthrough actually does, to be fair…When playing through the Vero, I only get options between PCM and Dolby Digital. Not Dolby Digital+.

So what exactly do I need to do to enable Atmos using my soundbar?

We have a guide that covers audio setup here…

https://osmc.tv/wiki/general/audio-hardware-and-software-configuration/

Did you switch your settings to expert view to get all the options and then enable passthrough? Also I don’t think you can get an Atmos stream though the Netflix add-on.

Excellent! The solution was to go into Expert-settings in System > Audio, and then there was TrueHD disabled by default that I had to enable. Strange decision to have it disabled as auto, but I suppose there is a reason for that. Anyhow, Atmos is working great now! :smiley:

The default audio settings allow audio output regardless of what the device is plugged into or what is being played. This does not seem strange to me at all.

3 Likes

I must be missing something. What’s the issue with allowing audio output regardless of which device is plugged in? Does it add latency? Wouldn’t it be possible for it to recognize if an output is not Atmos-capable, and then downsample to next level. Or maybe that is not possible. But anyway, to have it in the expert settings, when I assume most people buy the Vero4K+ to enable TrueHD Atmos, just seems a bit overlayered to me. But that’s just my very humble two cents, if all that. I also didn’t find it obvious from an interface point of view, how to change fram standard settings to expert settings. Its not located at a particularly focal point in the default skin, and I probably wouldn’t have found it if I wasn’t actively seeking it, knowing that Atmos support was hidden behind that layer. Don’t mean to be rude towards the front end coders, just striking a suggestion for plausible improvement, out there. :blush:

Every audio input device that connects via HDMI or Toslink can accept a two channel PCM signal. Support for bitstreaming any of the DTS or Dolby formats, as well as PCM in more than two channels depends on the equipment in the chain as well as what type of connection you are using. As such it is standard industry practice for audio output devices to only enable the universally supported format unless the user enables additional options in whatever setup menu the player has. This is not new or unusual behavior. AFAIK this has been the norm for decades. If a unsupported signal was sent by default then at best the person would get no audio and be left wondering why that was the default, and at worst who knows how a particular amplifier or soundbar would handle a digital signal it doesn’t understand.

3 Likes

It’s like if you made the default screen mode to be 4k60p, how would anyone without that video mode support view the image? Same for audio. People want audio working by default, they don’t want to have stuff broken when they plug it in.

Yes, sure. Figured it might be something along those lines. Just surprised it cannot somehow automatically detect it, and try with a downsampled signal one at a time until it finds the compatible one with the highest quality. Maybe not so easy to pull off. :slight_smile:

It can be detected if there is EDID metadata available. This may be something that gets added at some point.