Need help with fresh install

My Vero 4k has gone completely nuts. The IR remote control hardly had any control! BBC iPlayer is buffering like mad. So, I decided to do a complete re-install. Booting from a microSD card didn’t work but booting from a USB drive did.

Now I cannot work out how to configure OSMC back to how it was. I find Kodi the worst interface for configuring things. I try to remove the Pictures option from the main screen but it seems determined to search for pictures instead. Removing other items worked okay.

Then I have tried to add locations for Movies and TV shows. These reside on a TrueNAS box shared as windows shares. I can browse to them on all my computers but on the Vero4K browsing gives no results.

When I try to add a share manually I then try and tell it that movies reside there. It will not let me select that option.

I seem to have added the share twice in trying to get things to work and I can’t work out how to remove the duplicate.

On the old build movies would be displayed on the main screen. Now they are not.

I have Kodi on my main PC which I use to test things. It can see all the files on the TrueNAS box. I can play iPlayer programmes with no buffering.

So, what am I doing wrong? I’ve tried searching but everything seems to want to tell me how to setup a share. I don’t need that. It is how to configure OSMC to access the shares that I am finding difficult. I expected to click browse, find my server and have the shares listed.

Also, can someone please tell me how to watch ITVX etc on OSMC.

I am so fed up of the recent issues that I’m thinking of buying an Apple TV!!!

Everything was working fine until the last update when my remote issues started. BBC iplayer programmes would work with the remote until the buffering issues started. But playing video files on the server did not respond to the remote. I could play a video but not pause, rewind or stop it.

Are you using the supplied OSMC remote controller? This is RF based and should work quite well and does not rely on line of sight.

Perhaps you were using a different skin. By default, OSMC ships with two skins: the OSMC Skin and Kodi’s official skin (Estuary). You can switch between them under Settings → Appearance.

It sounds like you were using Library Mode. See

There is an ITV-X add-on for Kodi here: GitHub - dimkroon/itvx-for-kodi: Kodi addon to watch ITVX. It is not supported in an official capacity however.

Yes I’m using the RF remote on the new Vero4k but the problem I have had with the IR remote is nothing to do with line of sight. I can put the remote right in front of the IR receiver. The batteries are fine. The IR remote stopped working reliably after the last update. It would work just about okay in iPlayer but not when playing files from my TrueNAS server.

I always prefer to use IR remotes as I have Harmony remotes that control multiple devices. Using the RF remote is a pain.

In setting up the Vero4k to replace the one in the lounge it has been kind of weird. The interface is the same and today it is displaying movies as the lounge one does. But last night none were displayed.

Yesterday when clicking browse it did not find my server. Today it has. I have no idea why. Nothing changed from yesterday to today.

My problem now is that when I tried to get it browse my network I did it about 3 times for movies. Despite not finding anything it added the location 3 times. I used the same name each time and instead of telling me that the name was already registered it just added it 3 times. So now it thinks I have film, film2 and film3. I can’t find anyway of removing the last two.

Also, today I added a location for TV Shows. That worked except it got metadata for the shows that is complete rubbish. I can’t find any way of removing any of that info.

That is why I say that Kodi seems incredibly hard to configure.

It has always been my intention to build a media server running Jellyfin but I’ve found it difficult to find the right hardware to buy. So my current situation is just a stop gap.

After OSMC added the movie location 3 times and the meta data for TV Shows was such rubbish, I decided to re-install OSMC. But when I plugged in the USB drive with OSMC on and rebooted it just ignored the USB drive and booted the already installed OSMC.

So, that is current situation. I either need to know how to remove the extra network locations and the TV Show metadata OR I need to know how to get the Vero4k to recognize the USB drive and let me install from scratch again.

It seems to me there would be a great market for pre-built media servers. Finding the right hardware is a nightmare and then there is the issue of testing all the software. I am looking for an Epyc based motherboard to run TrueNAS Scale, NextPV¬R, and Jellyfin. But I can’t find anyone who has done that. But that is just an aside!

OK thanks for clarifying that you are using your own IR remote. I wanted to make sure there was no confusion with the supplied remote which is RF based.

There is a known issue where remotes are less responsive during playback. But when you are not playing anything they should be just fine. If they’re not, I’d check the batteries and the remote profile that you are using.

Can you show me a screenshot of the contents of the USB so I can make sure you wrote the image correctly?

The OSMC usb driv was written by the OSMC windows program for osmc-installer.exe and it worked yesterday. Is there a way of forcing it boot from the USB?

You need to re-run the installer on your PC after each use. This is so you don’t accidentally plug it in and erase the device again

I’ve never seen anything like that before but thanks… OSMC installs okay now.

Apart from most of the video add-ons I’ve installed not working I’ve managed to get the movies recognized. But I’m clearly doing something wrong with TV shows. It has the correct file access but is clearly not scanning the files.

What am I not doing that I need to do to sort this?

Really hard to say without some logs.

In my experience the remote is not just less responsive… It is totally unresponsive. This issue only started with the last update. I can press stop 20 times before it works and I’ve never got forward or back to work at.

I agree that the remote works other times but not working in playback makes it totally unusable.

Okay, back to the fresh install.

It feels to me like Kodi is a work in progress that is not ready for prime time.

I have re-installed and got movies displayed on the main movies screen. This appears to work okay.

The RF remote seems to work okay.

When I try to enter TV shows it says there are none in my library. If I try add them to my library and do metadata lookups the result is total rubbish. I have no idea how it gets the TV show data but absolutely nothing is correct.

I cannot find a way of editing the TV Show metadata or removing the location. So, I installed again and this time told it to use local file names. Doing this seems to load nothing into the library.

It seems as if the databases for TV Shows is US based and gets everything wrong.

Next I added Vivx and created an account on ITVX. All appeared to be okay but when I clicked on it I get nothing but errors.

Then I tried Catchup TV. Again, installation seemed okay but I got nothing but errors every time I tried to play anything. Something about routes

I have uploaded the logs to

One of the things I find really annoying about Kodi is that everything seems to fail and refer you to the log. Why can’t it just tell you what the hell went wrong instead of referring to a log all the time?

So, far most of the video add-ons I’ve tried fail. To make it worse the add-ons are not structured in a sensible way. It would make sense to list addons by country/language and indicate whether or not they are free.

With all of this I have tried on my PC as well as a Vero4k. On my PC Kodi just crashes.

The behaviour you describe with the remote misbehaving, and iPlayer buffering sound very much like the early stages of the issues that I experienced for some time, eventually getting to the point where my Vero 4K would reboot if you pressed down twice in quick succession, and then began to boot-loop, dying at the moment that it tried to switch video modes to show the normal display.

The cause of all that turned out to be a knackered power supply. If you have a spare 5v PSU available, give it a try.

Apparently it’s possible to power it via one of the USB slots if you happen to have the appropriate male-to-male cable around.

I only managed to confirm the problem by realising that I had a charger cable for my BT headset that exposes the terminals, so I could plug that into the Vero and check the voltage being supplied from the USB port, which was ~3.7v and wobbly IIRC. Checking the PSU in isolation was no good, because it can do 5.5v when there’s no load.

Having replaced the PSU, all is now well.

Oh, and in the middle of this, I too tried reinstalling, which mostly worked, but had some oddities (MyOSMC’s menus were a bit confused, among other things), which I now assume was due to some write failures during the install – reinstalling with a decent PSU fixed that.

Another symptom that I had for a while was that it would have bouts of 10-20% packet loss when pinging the local network, which of course will result in things like iPlayer buffering, so you might want to try logging in and pinging your local router to see if that’s what’s happening with you.


Cheers, Phil.