Need help with my CEC configuration

I’ve got the RC installed on my RPi2, and it’s working almost perfectly. Performance is great, but I have an issue with the way that CEC is interacting with my setup.

I have an Onkyo receiver which has all of my devices connected to it. Some of them are not CEC aware, so I use the receiver to control which input is directed to the TV.

Everything works well, and I’m able to use the TV remote to control the OSMC interface. However, occasionally, the input is switched to the RPi2, apparently when the TV is off overnight. Of course, this could be happening when the TV is powered on, which wakes up the receiver.

Ideally, OSMC would respond to CEC commands, meaning I can use the remote to control it, but it would not cause the input to switch to it in any circumstance.

I have hdmi_ignore_cec_init configured, so powering on the device doesn’t cause this switching, but is there some way to stop this happening at other times?

I’ve tried various combinations of CEC settings under Peripherals, but can’t seem to get the behaviour I want.