Need help with no WiFi raspberry pi 3

Someone said they solved their issue of no WiFi option by going to
My OSMC --> Pi Config -> Hardware -> Origin

When I go to pi config i have the following options : Display, GPU Mem &codec, hardware support and config editor. There is no option for origin under any of these…

Here are my logs
Https://paste.osmc.tv/gonaziwiqa

I also have no Bluetooth

Has it ever worked?

Please install and then run hwinfo

sudo apt-get update
sudo apt-get install hwinfo
hwinfo | paste-log

and post the URL

Https://paste.osmc.tv/lumaxeganu

WiFi used to work fine. Bluetooth never had but i read it isn’t ready out of the box and i haven’t taken the time to figure out how to set it up

hwinfo isn’t able to detect either the WiFi or Bluetooth interfaces – at all.

You don’t mention if this problem occurred after OSMC upgraded to the 4.19 kernl but I’m inclined to think that it’ could be a hardware problem.

You could first install rfkill and then run rfkill list.

If an installation of Raspbian Lite also fails, then that would confirm a hardware problem.

Someone mentioned that they simply changed their localization in pi config and it fixed the issue…but i can’t find any localization settings anywhere

No – you may need to change things if you’re in Germany, but you’d still see the WiFi option

You might have seen this on a Raspbian forum but AFAICT the problem is either with the hardware or perhaps it’s picking up the incorrect firmware

You should be able to change localization by running sudo dpkg-reconfigure locales

I installed rfkill, but when I try rfkill list even with sudo it says Can’t open RFKILL control device: No such file or directory

Trying rfkill was just a quick test.

Your next step should be to see if the same problem occurs on Raspbian Lite.

Is there a difference between raspbian and raspbian light? I tried raspbian and same thing. I just don’t understand how it would just suddenly stop working one day if it was a hardware issue

The other options come with a desktop environment and are larger.

Could you remove these lines from your config.txt, reboot, and see if that makes a difference.

core_freq=400  
arm_freq=1200  
boot_delay=1
sdram_freq=400

no no difference

It still looks like it might be a hardware issue. I found quite a few threads where people have experienced a loss of WiFi and Bluetooth on Pi3Bs.

I’d wager that it’s a hardware issue unfortunately.