Need help with transmission

Hi guys,
I’ve just installed OSMC on my Raspberry Pi 2 but even if I can connect via Transmission GUI from my PC I can’t download anything because the port seems closed.
I’ve checked on my router and on that side is ok.

I’ve tried just to add an iptables rule (sudo iptables -I INPUT -p tcp --dport 51413 -j ACCEPT) but the problem still persist.

Get rid of the iptables rule.
My bet is that the ip in the config is set to “localhost” (allow only local host) and not “” (allow all)

I’ve checked the “bind-address-ipv4” is on /home/osmc/.config/transmission-daemon/settings.json

Check the current ports in use

netstat -lnptu

Confirm the port as intended is really in use

Thanks for fast response!

The result of the command “netstat -lnptu | grep 51413” is:
tcp 0 0* LISTEN 348/transmission-da
tcp6 0 0 :::51413 :::* LISTEN 348/transmission-da
udp 0 0* 348/transmission-da

OMG I read bad :smile:

Didn’t read you have access to the GUI

So OSMC/Transmission are working as they should.

Your router port forwarding seems not to happen

It seems strange to me because on router I’ve enable the port forwarding for the 51413 TCP port to the ip address of the OSMC Raspy (I’ve just re-checked!) and before of buying the Pi 2 I’ve used a Raspy B+ with Transmission just disabling the firewall on Raspbmc settings… I’m reusing the same ip-address of the old Raspy (static DHCP rule on my router).
Why on the old Raspy with the same ip-address was working? :frowning:

Maybe the ipv6 my problem? How can I disable it from Transmission?
I only have to forward the TCP port, right?


I am getting a bit confused why it ain’t working. I am not at home to check my forwarding, but as far as I remember it’s TCP only.

Let’s do crazy, grab a different port for transmission

p.s. if editing transmission config file (not the GUI) while transmission is still running use:
pkill -HUP transmission-da
to make it keep the changes