Need some help mounting share with fstab

Hi all,

Happy users for several months now. When I first received my vero 4k+ i tryed mounting my NAS with fstab but never got it to work. Unfortunatly I dont have the skills to troubleshoot myself so I gave up on it and just had added a normale NFS source to the vero 4k+. Up till now I had no issues realy with the throughputt and everything worked fine, but a recently acquired file seems to be causing some issues. The maximum bitrate is around 80 Mb/s.

So I decided to have another go at trying to mount the share with fstab, however still not succesfull and I need some help.

I have been following the following tutorials:

The issue I’m facing is that the mount just doesnt seem succesfull or something, but im not getting any errors. I’ll post here what I’ve done with screens and hopefully I can get some pointers. Keep in mind though that I am not technical and work through tutorials and pretty much need step by step pointers.

Firstly I edditted my fstab file. This is how it currently looks:

Secondly a screen from the SSH terminal and the steps I took using the tutorial. As you can see below when I try to enter the directory it just wont do it. It lets me enter the volume1 mount but I cant seem to access the video mount. A sidenode, the ‘video’ mount is the correct one. I guess I’ve also added ‘Video’ just in case I think but that one isnt correct. The path is /volume1/video. When trying to open /volume1/video/1 it just says no such device.


The rights to the folders should be correct, i’ve also added a screenshot of the synology with the settings. Keep in mind the language is in dutch but should be clear enough. Also is the ip-adress of the vero.


When I open the vero 4k+ through the normal user interface and try to add the root share it lets me go to volume 1 and displays the video share. But when I add it as share it freezes and after 1-2 minutes does nothing.

So I think there is something wrong in the NFS rules of the synology but I have no clue what it is. So any help is much appreciated.


Whats the output of:

showmount -e 192.1681.230

Thanks Tom.

Output is:

osmc@Vero:~$ showmount e-
showmount: only one hostname is allowed

You miss typed the command

afaik I didnt. He mistyped the ip-address. 192.1681.230 should be cus thats the ip-address of the NAS. As far as the command goes, I dont see any typo’s.

showmount -e
showmount e-

Why are you putting the - after the e? Put it in front of the e

OMG that is so stupid. How did I not see that lmao.


osmc@Vero:~$ showmount -e
clnt_create: RPC: Port mapper failure - Unable to receive: errno 113 (No route to host)

That seems to indicate the OSMC device cannot see the NAS. Can you ping the NAS from OSMC?

What is the output of ifconfig On the OSMC device?


Have you got the firewall turned on the nas, is 192.1681.56 allowed in either for Mac/linux fiileserver (nfs) or All.

Possible stupid question but does the nas have a static IP is it set to dynamic/dhcp?

Thanks Tom.

The NAS has static IP. Firewall of the NAS is turned off.

I can ping the NAS through SSH of the Vero. Not sure what you mean with ipconfig, are you expecting an output through SSH or just the normal config?

I just grabbed some stuff through SSH, if it contains stuff that I shouldnt post on the internet please let me know so i can delete it :stuck_out_tongue:

osmc@Vero:~$ hostname -i
osmc@Vero:~$ netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface UG 0 0 0 eth0 U 0 0 0 eth0 UH 0 0 0 eth0
osmc@Vero:~$ ipconfig
-bash: ipconfig: command not found
osmc@Vero:~$ /sbin/ifconfig
inet netmask broadcast
ether c4:4e:ac:29:33:92 txqueuelen 1000 (Ethernet)
RX packets 322386125 bytes 484662844021 (451.3 GiB)
RX errors 0 dropped 556 overruns 0 frame 0
TX packets 40841840 bytes 3380959796 (3.1 GiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 40

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 4096
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 0 (Local Loopback)
RX packets 823 bytes 75468 (73.6 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 823 bytes 75468 (73.6 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

The NAS has static IP. Firewall of the NAS is turned off.

I need to clear something up, in the original posts it mentioned as IP-address. I noticed this was an old IP from a previous NAS that i’ve replaced. The new ip-address is So i’ve change the fstab file and editted the ip-address, and did all the steps again.

Unfortunatly not succesfull though, error:

osmc@Vero:~$ sudo mount /mnt/volume1/video
mount.nfs: access denied by server while mounting

I also grabbed some logs:

Even with the correct IP address, your fstab won’t work. /mnt/volume1/video        nfs     noauto,x-systemd.automount  0  0

This should be: /mnt/volume1/video        nfs     noauto,x-systemd.automount  0  0

I’d have chosen something like /mnt/video as the mount point, but that’s just a personal preference.


@dillthedog You are the man, its working now. Awesome! Thanks so much :smiley:

1 Like