Netflix Error "TypeError:__init__() missing 2 required keyword-only arguments: 'request' and 'response'"


Hoping if someone can help me out with this problem:-

TypeError:init() missing 2 required keyword-only arguments: ‘request’ and ‘response’

I have looked at castagnaIT’s github page, the problem has been reported by another user but there is no solution posted.

I haven’t tested Netflix addon in OSMC to any extent, since Bullseye upgrade testing. Anyway that error message seems to be more addon related then OSMC.

But there are a few questions I wanna ask, in a diagnostic, elimination wy:

Might be OSMC related:

Have you installed python3 cryptography modules?
Is InputStreamAdaptive addon enabled?

Addon related:

Is ISA_helper installed?
Has ISA-helper run once since Netflix addon been installed?
Have you tried the Netflix-addons github issue page?

I’m guessing either someone has fiddled with you addon settings or code, or you have some kind of filesystem errors (SD-card breakage?) making the netflix addon none compatible.

I have installed the crypto modules. Netflix was working fine until this error popped up.

Tried installing the cryptography module, got a build error asking to upgrade pip. Now my boot screen won’t show up (think my pi device is acting faulty). Will reinstall OSMC again.

ISA-helper is installed but I do not know how to use it.

I did have a look at CastagnaIT’s github page for this problem, but no solution has been posted.

Symtom on symtom of a SD-card giving up the ghost. You could try to reinstall on current SD-card, but once system are loading what it thinks are “healthy files” and get less then optimal results, a reinstall will just prolong the agony, with “mysterious errors coming more regularly”. Sure you can do a reinstall and hope for the best, but i recommend you get another SDcard for replacement, as soon as possible. And that from a reputable vendor, that will accept they might unknowingly sold you a fake, if that happens. EG. stay off the cheap once from wish/ali/“name_your_pirate_seller_her” =)

After more digging, there is an issue, there is a branch on github with a fix. under issue #1425 called t2, bransh was “rework something”, I closed that tab by mistake while posting this, and the Mrs is giving me the evil eye.

Looks like he released a new version that fixes the error (just when my micro SD card decides to act faulty). Anyways once I get my Pi device working, will try the latest netflix update.

Thanks so much.