Netflix not working anymore

Evening all here…

I start a new thread here, please admin’s if it’s the wrong place, feel free to move it.
I have been trying for few day’s now for getting my netflix up and running again. I donno if it was some automatic update which killed netflix, so i decided to do a fresh install of my Vero 4K box.
I downloaded the OSMC_TGT_vero3_20180103.img, and dd’et it onto a usb and did a reinstall. After that following instructions to upgrade to kodi 18 alpha, and installed the netflix addon.
Netflix starts, and i can login and choose series/movies, but i got error when starting the stream.

At end of log, there is a lot of “netflix/python etc…” error’s.

I was hoping someone can hint me, what could be wrong ?

Full log from clean stretch .img install + netflix
https://paste.osmc.tv/osugeyucaw

20:36:39.680 T:3614434048 NOTICE: Creating InputStream
20:36:43.817 T:3718247168 ERROR: Traceback (most recent call last):
20:36:43.817 T:3718247168 ERROR: File “/usr/lib/python2.7/SocketServer.py”, line 290, in _handle_request_noblock
20:36:43.818 T:3718247168 ERROR: self.process_request(request, client_address)
20:36:43.818 T:3718247168 ERROR: File “/usr/lib/python2.7/SocketServer.py”, line 318, in process_request
20:36:43.819 T:3718247168 ERROR: self.finish_request(request, client_address)
20:36:43.819 T:3718247168 ERROR: File “/usr/lib/python2.7/SocketServer.py”, line 331, in finish_request
20:36:43.819 T:3718247168 ERROR: self.RequestHandlerClass(request, client_address, self)
20:36:43.819 T:3718247168 ERROR: File “/usr/lib/python2.7/SocketServer.py”, line 652, in init
20:36:43.819 T:3718247168 ERROR: self.handle()
20:36:43.819 T:3718247168 ERROR: File “/usr/lib/python2.7/BaseHTTPServer.py”, line 340, in handle
20:36:43.820 T:3718247168 ERROR: self.handle_one_request()
20:36:43.820 T:3718247168 ERROR: File “/usr/lib/python2.7/BaseHTTPServer.py”, line 328, in handle_one_request
20:36:43.820 T:3718247168 ERROR: method()
20:36:43.820 T:3718247168 ERROR: File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSLHttpRequestHandler.py”, line 59, in do_GET
20:36:43.820 T:3718247168 ERROR: data = MSL.load_manifest(int(params[‘id’][0]))
20:36:43.821 T:3718247168 ERROR: File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSL.py”, line 236, in load_manifest
20:36:43.822 T:3718247168 ERROR: return self.__tranform_to_dash(data)
20:36:43.822 T:3718247168 ERROR: File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSL.py”, line 326, in __tranform_to_dash
20:36:43.822 T:3718247168 ERROR: manifest = manifest[‘result’][‘viewables’][0]
20:36:43.822 T:3718247168 ERROR: KeyError: ‘viewables’
20:36:43.822 T:3614434048 ERROR: CCurlFile::FillBuffer - Failed: Server returned nothing (no headers, no data)(52)
20:36:43.822 T:3614434048 ERROR: CCurlFile::Open failed with code 0 for http://localhost:49856/manifest?id=80017451
20:36:43.822 T:3614434048 ERROR: AddOnLog: InputStream Adaptive: Cannot download http://localhost:49856/manifest?id=80017451
20:36:43.822 T:3614434048 ERROR: AddOnLog: InputStream Adaptive: Could not open / parse mpdURL (http://localhost:49856/manifest?id=80017451)
20:36:43.823 T:3614434048 ERROR: CVideoPlayer::OpenInputStream - error opening [http://localhost:49856/manifest?id=80017451]
20:36:43.824 T:3614434048 NOTICE: CVideoPlayer::OnExit()

Hi,

There is an issue with widevine, its now not being included in the nightlys as we are nolonger able to distribute it. I think you can install it manually

[TESTING] Kodi 18 (Leia) builds for Raspberry Pi - #721 by joakim_s

Thanks Tom.

Also see here… This explains it in more words: nss/nspr libraries · Issue #420 · osmc/osmc · GitHub

@samnazarko I would actually advise you to not include libwidevinecdm as part of OSMC because redistribution of the binary breaks the EULA.

"Google Inc. and its affiliates ("Google") own all legal right, title and
interest in and to the content decryption module software ("Software") and
related documentation, including any intellectual property rights in the
Software. You may not use, modify, sell, or otherwise distribute the Software
without a separate license agreement with Google.  The Software is not open
source software.

If you are interested in licensing the Software, please contact
widevine@google.com.
1 Like

Depending on when you did the upgrade to v.18 you might not have gotten the libwidevine libary, I’m currently trying to make a simpel guide on howto install them yourself since we cant redistribute them. I think i might have it done later tonight or early tomorrow (22:40 here now)

Hi…

So i tried another reinstall with stretch image + netflix, but still got playback error.
Joakim_Sandstrom pm’ed me a very clear guide, also including the libwidevinecdm.so

Anyone else also have this issue?

I did not activate logging, but there is a log anyway, where one can see what’s going on!
I tried playing some serie a few time for filling the log.

full log here https://paste.osmc.tv/unawitenew

osmc@osmc:~$ ldd -v libwidevinecdm.so
libstdc++.so.6 => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 (0xf6c06000)
libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0xf6b8e000)
libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0xf6b65000)
libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xf6b41000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xf6a53000)
/lib/ld-linux-armhf.so.3 (0xab0b2000)

Version information:
./libwidevinecdm.so:
libc.so.6 (GLIBC_2.4) => /lib/arm-linux-gnueabihf/libc.so.6
libgcc_s.so.1 (GCC_3.5) => /lib/arm-linux-gnueabihf/libgcc_s.so.1
libgcc_s.so.1 (GCC_3.0) => /lib/arm-linux-gnueabihf/libgcc_s.so.1
libgcc_s.so.1 (GLIBC_2.0) => /lib/arm-linux-gnueabihf/libgcc_s.so.1
libstdc++.so.6 (CXXABI_1.3) => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
libstdc++.so.6 (GLIBCXX_3.4) => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
libstdc++.so.6 (GLIBCXX_3.4.15) => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
libstdc++.so.6 (GLIBCXX_3.4.5) => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
libstdc++.so.6 (GLIBCXX_3.4.9) => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
libstdc++.so.6 (CXXABI_1.3.1) => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
libstdc++.so.6 (GLIBCXX_3.4.14) => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
libpthread.so.0 (GLIBC_2.4) => /lib/arm-linux-gnueabihf/libpthread.so.0
ld-linux-armhf.so.3 (GLIBC_2.4) => /lib/ld-linux-armhf.so.3
libm.so.6 (GLIBC_2.4) => /lib/arm-linux-gnueabihf/libm.so.6
/usr/lib/arm-linux-gnueabihf/libstdc++.so.6:
ld-linux-armhf.so.3 (GLIBC_2.4) => /lib/ld-linux-armhf.so.3
libgcc_s.so.1 (GCC_3.3) => /lib/arm-linux-gnueabihf/libgcc_s.so.1
libgcc_s.so.1 (GCC_3.5) => /lib/arm-linux-gnueabihf/libgcc_s.so.1
libgcc_s.so.1 (GCC_3.0) => /lib/arm-linux-gnueabihf/libgcc_s.so.1
libm.so.6 (GLIBC_2.4) => /lib/arm-linux-gnueabihf/libm.so.6
libc.so.6 (GLIBC_2.18) => /lib/arm-linux-gnueabihf/libc.so.6
libc.so.6 (GLIBC_2.17) => /lib/arm-linux-gnueabihf/libc.so.6
libc.so.6 (GLIBC_2.4) => /lib/arm-linux-gnueabihf/libc.so.6
/lib/arm-linux-gnueabihf/libm.so.6:
libc.so.6 (GLIBC_PRIVATE) => /lib/arm-linux-gnueabihf/libc.so.6
libc.so.6 (GLIBC_2.4) => /lib/arm-linux-gnueabihf/libc.so.6
/lib/arm-linux-gnueabihf/libgcc_s.so.1:
libc.so.6 (GLIBC_2.4) => /lib/arm-linux-gnueabihf/libc.so.6
/lib/arm-linux-gnueabihf/libpthread.so.0:
ld-linux-armhf.so.3 (GLIBC_2.4) => /lib/ld-linux-armhf.so.3
ld-linux-armhf.so.3 (GLIBC_PRIVATE) => /lib/ld-linux-armhf.so.3
libc.so.6 (GLIBC_PRIVATE) => /lib/arm-linux-gnueabihf/libc.so.6
libc.so.6 (GLIBC_2.4) => /lib/arm-linux-gnueabihf/libc.so.6
/lib/arm-linux-gnueabihf/libc.so.6:
ld-linux-armhf.so.3 (GLIBC_2.4) => /lib/ld-linux-armhf.so.3
ld-linux-armhf.so.3 (GLIBC_PRIVATE) => /lib/ld-linux-armhf.so.3
osmc@osmc:~$ ls -all .kodi/cdm
total 5012
drwxr-xr-x 2 osmc osmc 4096 Jan 20 09:16 .
drwxr-xr-x 8 osmc osmc 4096 Jan 20 08:15 …
lrwxrwxrwx 1 osmc osmc 54 Jan 20 09:16 libssd_wv.so -> /usr/lib/kodi/addons/inputstream.adaptive/libssd_wv.so
-rwxr-xr-x 1 osmc osmc 5122508 Aug 28 2015 libwidevinecdm.so
osmc@osmc:~$

need debug log to see more specidic where the fail is at.

Hey there :sunglasses:

I removed old log files, enabled debugging log and reboot.
After that started netflix, and when error occured, i grab the logs here…

https://paste.osmc.tv/kagagucugu

So it should be as fresh as possible.

rgds; Jesper.

@lykkedk, just wondering if you got anyother plugins install, tried myself with viaplay plugin and that crashed Netflix due to inputstreamhelper.

Since i haven’t got v.18 on my vero4k, but rather playing it loose with my pi2, there are some differanses in log file. But at a point where my pi2 log recognises:
DEBUG: [Netflix] codec is: aac

Your Vero4k seem to crash and burn with:

12:08:06.943 T:3694650112   ERROR:   File "/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/MSL.py", line 326, in __tranform_to_dash
12:08:06.943 T:3694650112   ERROR:     manifest = manifest['result']['viewables'][0]
12:08:06.943 T:3694650112   ERROR: KeyError: 'viewables'

Will negotiate with the mrs about experiment with the Vero4k, which is the main media supplier with iptv and such.

Goodmorning there :roll_eyes:

I feel stupid… error was duo to faulty ip adress of my vero 4k box in my iptables :sunglasses:

Normally netflix complains about some geoblock or whatever, but it just “crashed”!

So sry. for bother, problem is fixed and i can confirm that youre script and guide is working as it should!

Rgds; Jesper.

I would like to give a try to this script myself.

Can anyone PM me or post here?

Thanks