Netflix not working on latest OSMC

Hi there! I have the latest version of OSMC running on a Raspberry PI3 Model B+. Ever since I updated it Netflix stopped working.

Any idea what’s going on? Or the right way to uninstall anything Netflix related, including widevine so I can install it fresh.

Thank you for your attention!

Well uninstalling Netflix before upgrading Netflix Add-on is recommended.

libwidvine is installed in system, not in Kodi, so it’s not an easy thing to uninstall.

How did you install it before?? My install instructions limited pycryptodomex to 3.7 previously, but I have now updated to the latest, might be another reason why the newest is not working properly.

My recommendation, is uninstall Netflix add-on and then download and run my prep-script again. Should get you up and going.

But most likely is that you are running an old Netflix add-on, since a week back you had to upgrade to 0.13.23 or 0.14.5, since Netflix changed something in their authentication protocols


I am currently running Netflix 0.13.22, it seems to be the latest version. If I remember correctly, I think I used this guide to install netflix: RPi streaming station with Amazon Instant Video and Netflix | laclaro

Ok, I will remove Netflix and reinstall according to your instructions. This is the prep-script you are referring to, right? [HOW-TO ALL PLATFORMS]Can I use Netflix on OSMC?(post 4) - #4 by joakim_s

Thank you for helping!!

Yes that’s the script

1 Like

It works! Thank you!!

1 Like

Having same issue. Disabled & removed netflix but not associated data.
download latest script that installed at version 0.13.20 but can only upgrade to 0.13.22. so ended up with same issue. i.e. 0.13.23 not in list of available versions that I can switch between. I see on Github they are at 23. What do I need to do to get netflix update to pull this build?

My bad. Too many netflix zip files in home directory. All good once I installed from correct zip.

1 Like

Hi again. I didn’t want to open a new thread so I’m writing here. Everything worked fine for a few days then it started throwing an error. I removed Netflix, reinstalled it just like before according to @joakim_s but it prompts the same error. I can log in, I can click on my profile, sometimes I can even explore a TV Show and when I click on the episode it seems like it’s gonna load it and then loads forever before throwing this error below. Sometimes if I don’t click OK on the error screen the sad face emoji appears and osmc restarts.

Any ideas? I tried logging, it doesn’t seem to work properly. After this error the SSH connection is also interrupted and I can’t connect without a reboot. Which is weird af.

Please explain.

I restarted OSMC after I couldn’t SSH into it(after that netflix error). Then I copied the log file from before the restart to my PC and explored it, doesn’t seem to contain everything about the Netflix addon, just general info about OSMC and what it loads at start. I will try this again in a bit and come back with updates

Well… Murphy’s law in full effect. I tried again and it seems to be working now. I’m starting to think this is a network issue because it’s taking forever to load a movie/tv-show. Will do further testing tomorrow. Thanks

I am unable to log in. I am using Netflix 14.6 and it was working fine last week, but now I receive the message: Please check your credentials. I have uninstalled Netflix, removed all associated data, reinstalled after using your Prep-script on Putty, and entered my Name and Password as I have done in the past. Still get the same response from the addon. Any other suggestions. BTW, I have exactly the same problem with Netflix on Raspbian, and LibreElec.

Hmm strange, no login problems reported at the add-ons github page.

Uninstall Netflix add-on and then

rm -rf /home/osmc//.kodi/userdata/addon_data/

then in

rm *.challange
rm *.init
rm *.response

Reinstall the addon, Should be enough to install from addon dir, since you got the latest add-on downloaded.

Thanks for your quick reply. All is working fine now

1 Like