Netflix on Kodi 18

#1

Hello,

I just installed OSMC on my Pi 3 B+.
Now I read Kodi 18 supports Encrypted VideoStreams like Netflix.

But I can’t find which Version of Kodi OSMC installed nor any Addons to isntall.

How do I check which Kodi Version I installed and how can I install Addons and watch Netflix via it?

Also some day I wanna play play on my Pi.
Is retrosmc beta 0.007 kinda stable or is there a better Solution for this?

Or is OSMC the wrong distri for this?
I also tried installing LibreELEC, but I only got the Error with the lighning in the top right corner, which usually means a too weak power supply, but 3Ampere should be enough, right? And OSMC can boot

Is it also possible to have a XFCE-Desktop on my Pi with OSMC?

Thanks.

0 Likes

#2

OSMC-kodi version 18 is just around the corner, right now stable is still 17.6. If you want instructions on getting Netflix on your OSMC device i recommend this thread:

This guides you to install the latest nightly and then prepare for the netflix addon to be installed.

When you got Kodi 18 installed you got access to Retroplayer(still haven’t got support for all emulators RetrOSMC got), but i got GBA, NES, SNES, ScummVM and SEGA master/genesis running.

To install X-windows eviroment there is this thread:

Changeing windowmanager you have to figure out yourself, it comes with LXde.

0 Likes

#3

Is there a relesedate when 18 final will be released?

0 Likes

#4

No.

1 Like

#5

When I tried to install Kodi 18, I get an Error about a wrong Signature of the repository:

I added the Key via

root@osmc:~# wget -qO - http://download.osmc.tv/dev/gmc-18/gpg.key | sudo apt-key add
OK

but then I get

root@osmc:~# sudo apt-get update
Err:1 ftp.fau.de/osmc/osmc/download/dev/gmc-18 gmc-18 InRelease
The following signatures were invalid: EXPKEYSIG 326674E68C015D46 Greg McCarthy     <greg@gjmccarthy.co.uk>
Get:7 http://security.debian.org stretch/updates/main armhf Packages [460 kB]
Reading package lists... Done
W: GPG error: URL HERE: The following signatures were invalid: EXPKEYSIG 326674E68C015D46 Greg McCarthy <greg@gjmccarthy.co.uk>
E: The repository is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

What do I have to do here to have the signature accepted?
And why is it trying to download from ftp.fau.de and not download.osmc.tv as it says in the sources?

0 Likes

#6

Sorry my guide had not been updated with the right key, since it was update. Try this:

wget -qO - http://download.osmc.tv/dev/gmc-18/pubkey.asc | sudo apt-key add -

Will change the guide now.

0 Likes

#7

That worked thanks, but now I have another Issue.

I can no longer access My OSMC -> App-Store.
It shows me the “Apps”, but pressing a button does not change to the next App. It still gives me a sound then I press Up- or Down-Arrow though.
I was in this Menu in Kodi 17.x and there it worked.

Is this a know Bug in Kodi 18?
Or did installing the netflix addon cause this?

Anyways, if there is no quick Way to fix this:
How do I enable Samba-Filesharing via SSH?

Can the Emulator of Kodi 18 also emualte Amiga?

0 Likes

#8

Okey, the “MyOSMC”-bug regarding app-store is known, you can work around that with a mouse connected and move the pointer to hover over the first selection, then you can navigate using your normal way.

Here’s how to install samba-file sharing via ssh:

sudo apt-get install smb-app-osmc

Retroplayer doesn’t support Amiga on Pi yet, as far as i’ve seen.

0 Likes

#9

Tahnks.

I tried to some games, but it doesn’t work.
I copied some snes,nes,gba roms onto my pi, but i cant start them.
I added the fodlers in Games, but it cant see them.
Also I have seen in a youtube video, that you should be able to choose which emulator to start, but I can’t choose any…
Is this maybe because I have the OSMC Skin isntalled?
How do I revert to the Kodi one?

0 Likes

#10

In order to get the games to play, you need to enabled the emulator for the games:

For NES i use QuickNES, got Settings ->Add-on browser -> My add-ons -> Game add-ons -> Emulators and enable Nintendo - NES / Famicon (QuickNES)

Next step is to install the controller profile needed, go back to Add-on browser -> Install from repository -> Game add-ons -> Controller profiles, install and enable NES Controller.

There are alot of the emulators, some work some doesn’t, some are better with certain rom files. It’s a trial and error. But all emulators needs controller profiles installed, and i think the will tell you when you try to run the emulator which profiles are needed for that emulator.

0 Likes

#11

For some Reason Netflix lags often.
What can I do to prevent this?
The Sound is fater than the Picture and there are stutters in the picture.
Then every ~30 secs everything stops for some seconds.

First I thought this was my Wifi connection, but now with Cable (1000mbit) I have the same problem.

Is there anything I can do about this?

0 Likes

#12

Make sure omx player is off and mmal is on in Kodi settings.

0 Likes

#13

Where is that? I can not find any Kodi settings / choosing the Player setting in OSMC.

0 Likes

#14

Did you enable advanced or expert menu level in the bottom left?

0 Likes

#15

I don’t think so, how do I do that?

0 Likes

#16

Sorry, I meant bottom left. Just open the settings menu.

0 Likes

#17

No menu open, when I click in the left or right bottom corner.
I can press “S” and then I am in the normal settings menu, but there is no setting to choose a player?

0 Likes

#18

Go to the settings menu and then at the bottom left you will see standard press on it till it is on expert.

0 Likes