Netflix Widevine update issue OSMC

Hi, been using Netflix 0.15.2 successfully for a while on Pi 3+, but it just demanded I update Widevine, then the update fails to install after successful download. I saw somewhere else a recommendation to downgrade to 0.14.6, tried that, same issue.

If anyone else has this issue, please post any workaround.

Also, if you need to delete failed ChromeOS images to make space for new attempts, the images are in home\osmc\ .kodi\userdata\addon_data\script.module.inputstreamhelper\tmp. Took me ages to find them.


1 Like

There is a new inoutstream.helper that downloads the newest libwidevine.

Thanks Joakim. Any chance of pointing me towards a procedure for finding and installing this inputstream.helper?

1 Like

Should help you


same here with Amazon VOD.

Thanks Joakim, that has worked a treat. Just a small typo in your instructions, should be cd /home/osmc/ .kodi/addons. (If you use standard installation instead of Joakim’s custom script).

Just to add this works on Netflix 0.14.6 and 0.15.2.

Those instructions was for those that have used my script, which downloads the netflix addon to a folder called addons in /home/osmc that’s why i used that path and not .kodi/addons

OK Joakim, I will edit my post to make that clear for all.

Thanks again, I appreciate your efforts.

This worked like a charm. Thank you.

Scratch this. I solved my problem. I disabled OMXPLAYER (left MMAL player enabled) and that brought back both video and audio.Everything is fine now.


I’ve run into an interesting issue. Not sure if it’s directly related to this, tho.

Running RPI3/OSMC/ext. HDD/1080 TV. I followed the directions above for installing the widevine stuff. Netflix addon is ver. 15.8. When I first started a video on Netflix it asked to install widevine, which it did.

It appears that the movie is “playing” but the screen is blank (as in dark). If I hit “i” for info, I get that screen showing and it shows the movie is playing (time is changing, both elapsed time and time remaining), but no video (or audio). Also, if I hit “Pause”, I get a large “Pause” in the middle of the screen. If I hit “Stop”, I get the movie still shot as the “wallpaper”. Everything else seems to be normal.

Any insight? Thx and cheers…