Network Bandwidth Issues

Hi, I seem to be having similar issues to this thread: Vero 4K + network speed major disappointment - #294 by sam_nazarko

In my particular case I can get gigabit speeds, they last for about 60 seconds in iperf3, but then they just completely drop away. There is no consistent gigabit speeds with the Vero 4k+ Sometimes they come back, sometimes they don’t. I’ve tested multiple cables and believe I have eliminated them as a problem. When I plug a laptop into the same cables in the same location I consistently and repeatedly get gigabit speeds via iperf3, which suggests to me its the device (drivers or hardware).

iperf3 logs here: Dropbox - iperf3 logs.txt - Simplify your life

Any help appreciated.

When did you order the device?
Units shipped after 30.09 shouldn’t have any issues

Please use the osmc pastebin as people are reluctant to download logs, which DropBox mandates

Can you also upload full logs?



Thanks for very fast response Sam. I’ll do as suggested re logs and osmc pastebin.

Device was ordered 2 November 2018.

Thanks – will keep an eye out for this.
Just to confirm: you ordered from us, i.e.


Hi @sam_nazarko. I have no idea what happened, but when i went to reproduce some logs i’m now getting perfect gigabit speeds. It’s certainly a great surprise, as I could’ve provided multiple logs from earlier that day/that week, showing the speed dropping away and in fact the machine hadn’t worked properly with speeds until after i’d tried everything and opened a ticket. I can only put it down to Murphy’s Law. Kindly close the ticket and if the problem resurfaces ill create a new one.

Let’s keep an eye on things.
Let me know if things crop up.

Today’s update also includes a fix for IRQ issues on the Gigabit Ethernet adapter; which will likely fix up the final few quirky issues, so be sure to grab that.