Network connection

Hi, Last night I had a network connection but today nothing!
It is a wired connection, I have tried wireless but nothing there either.
I have looked through old posts but sadly I have not found the same issue, close but not the same.
I have done all the usual turning things off, Vero and router, and switching them back on again but no change.
I have also tried changing cables and ports on the router but the problem persists.
The Vero 4K+ is showing on the router.
Link: Connected
Mac address: Busy
Internet: Busy

It is several years since I have had a network problem and that was before I got the Vero 4K+ and I cannot remember how that was overcome.

Any ideas?

Have you checked under My OSMC → Network to see if a connection is active?

It says Status: eth0 (No internet)

Are you using DHCP or Static IP?
If DHCP are you seeing an IP in the wired section?

Configure Network using DHCP is highlighted and there is an IP address.

1 Like

If I click on Configure using DHCP it blacks the IP address etc out.

Whats the IP and Gateway IP? Does it match your LAN?
What happens if you go to MyOSMC → Log Uploader and try to upload logs?

IP address is 192.168.0.101
Default Gateway 192.168.0.1

They do match the LAN

Does uploading the logs work?
Can you ping 192.168.0.101 from a device on your Lan?

Tried to upload logs and got the message “Could not retrieve URL”

OK try to ping the IP. Could it be a IP Address conflict?

I can ping the IP address okay.

Can you connect via SSH or Web browser?

Yes I can SSH in

Then it must be a DNS, Router or firewall problem.
Connect via SSH and show output of
ping 8.8.8.8
ping www.google.com

osmc@osmc:~$ ping 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes

64 bytes from 8.8.8.8: seq=0 ttl=114 time=30.611 ms

64 bytes from 8.8.8.8: seq=1 ttl=114 time=25.458 ms

64 bytes from 8.8.8.8: seq=2 ttl=114 time=25.200 ms

64 bytes from 8.8.8.8: seq=3 ttl=114 time=27.505 ms

64 bytes from 8.8.8.8: seq=4 ttl=114 time=32.322 ms

64 bytes from 8.8.8.8: seq=5 ttl=114 time=29.770 ms

64 bytes from 8.8.8.8: seq=6 ttl=114 time=31.989 ms

64 bytes from 8.8.8.8: seq=7 ttl=114 time=29.376 ms

64 bytes from 8.8.8.8: seq=8 ttl=114 time=29.227 ms

64 bytes from 8.8.8.8: seq=9 ttl=114 time=28.892 ms

64 bytes from 8.8.8.8: seq=10 ttl=114 time=28.769 ms

64 bytes from 8.8.8.8: seq=11 ttl=114 time=28.631 ms

64 bytes from 8.8.8.8: seq=12 ttl=114 time=30.963 ms

^C

— 8.8.8.8 ping statistics —

13 packets transmitted, 13 packets received, 0% packet loss

round-trip min/avg/max = 25.200/29.131/32.322 ms

osmc@osmc:~$ ping www.google.com

ping: bad address ‘www.google.com’

osmc@osmc:~$

Means you have a DNS problem.
Check on the Wired page which DNS server is configured and if that ist correct

The DNS servers primary and secondary are the same as they have always been.

I have changed the primary DNS number and it appears to have done the trick!
Thank you for your help in pointing me in the right direction.
Great support.

Hi
I have the same problem but with RPI4 but
I can ping
I can connect with ssh
ip 10.0.4.12 (fixed ip address RPI4)
gateway 10.0.4.1 (router)
I pinged to cloudflare 1.1.1.1 and it seems ok
I pinged to www.cloudflare.com and it seems ok

still Tried to upload logs and got the message “Could not retrieve URL”

any idea please ?