Network Issue PI 4

Hi and good day
Let me start
I am not a programmer and are only learning now
My issue is the following
I have a PI 3 running OSMC KODI 19.1 no problem but when i did a fresh install it came up with the following error “OSMC Network Setup Unhanded Exception Caught”
i then reverted back to Kodi 18.9 and did an upgrade to Kodi 19.1 via the internet and it was working fine…By the way i has been running Kodi 18 for the past two years on the PI 3 B+ No problems
Then i did a fresh install on a new mem card for my PI 4 4Gig it also came up with the network setup error …Also tried it with My PI 4 8 Gig same issue
I had a issue previously with the PI 4 4 Gig running the Raspbian operating system and then found some help from a guy that where i had to create a file called “wpa_supplicant.config” which i had to put in the boot directory and it worked for the issues with the networking
I tried to do the same for OSMC operating system but i cant access the boot directory permissions as it is protected
I also tried wireless and wired connections via the OSMC setup but to no avail and note some people had success doing it also a fresh install that helped in my case none worked
Like i said am not a good programmer trying to learn …Is there anybody that can help me with this
I also went thru the issues that was raised in the OSMC Forums but could not find any help with my problem
Kind regards Schalk

Did you tried to preconfigure your network in the installer (preseed)?

Yes did that

That function currently has a problem. Don’t preconfigure and just configure after installation via MyOSMC → Network.

Will be fixed in the next version.

Thank you …thank you…thank you… Got it working i owes you guys and girls a beer or two