Network issue since september update

September update just installed and I am unable to access my network disks via smb.

I get those message when trying to browse:
“Software caused connection abort”
“Couldn’t connect to network server”

What is your SMB server? Is it configured with SMB1 or SMB2?

Please upload logs to help us investigate more.

Ah just checked, my NAS was allowing upto smbv1 only.
I switched to upto smbv3 and it’s working now.

Thx.

So this means the update made the vero switch to a higher smb version by default I suppose.

smbv1 is disabled due to security issues

1 Like

SMBv1 has been disabled for some time.

SMBv1 was working great on my Vero4k with march22 update.
But indeed, since September22 update, I cannot access my old NAS anymore.
It there a way to get SMBv1 support back ?

In Service/Smb settings, forcing both minimal and maximal version to SMBv1, has solved for me the issue. Can’t remember what was my parameters before, but after updating to last upgrade, settings were set to minimal = default, maximal = Smbv3

2 Likes

Thank you! This worked perfectly!

Thank you - exact same issue here on Vero 4k - changing min and max to smbv1 fixed it:)

I’d like to add that in my case it was sufficient to define the minimal value as “SMBv1” and keep the maximal value as “SMBv3” in order to get my SMB mounts back to work.
From what I remember, my old Lacie NAS only supports SMBv2, so probably the latest OSMC release has the default behavior that as long as no minimum version is defined, the minimum supported is in fact SMBv3.