Network issue since september update

September update just installed and I am unable to access my network disks via smb.

I get those message when trying to browse:
“Software caused connection abort”
“Couldn’t connect to network server”

What is your SMB server? Is it configured with SMB1 or SMB2?

Please upload logs to help us investigate more.

Ah just checked, my NAS was allowing upto smbv1 only.
I switched to upto smbv3 and it’s working now.


So this means the update made the vero switch to a higher smb version by default I suppose.

smbv1 is disabled due to security issues

1 Like

SMBv1 has been disabled for some time.

SMBv1 was working great on my Vero4k with march22 update.
But indeed, since September22 update, I cannot access my old NAS anymore.
It there a way to get SMBv1 support back ?

In Service/Smb settings, forcing both minimal and maximal version to SMBv1, has solved for me the issue. Can’t remember what was my parameters before, but after updating to last upgrade, settings were set to minimal = default, maximal = Smbv3


Thank you! This worked perfectly!

Thank you - exact same issue here on Vero 4k - changing min and max to smbv1 fixed it:)

I’d like to add that in my case it was sufficient to define the minimal value as “SMBv1” and keep the maximal value as “SMBv3” in order to get my SMB mounts back to work.
From what I remember, my old Lacie NAS only supports SMBv2, so probably the latest OSMC release has the default behavior that as long as no minimum version is defined, the minimum supported is in fact SMBv3.

I have a Macbook and I connect to my Vero4k+ over the network to manage files (to add and delete files). I do this by using Finder and the GO > Connect to Server.

During the past two days after an update, I can connect to the SMB server (smb:// but after a while the connection dies and I cannot reconnect with the Macbook.

After a while I can reconnect but then the last directory I was in is greyed out. When I say directory, I mean that I have a microSD card for movies and a USB stick for TV shows.

I have to actively disconnect via Finder and then reconnect and then I can see all directories.

I have an odd solution for my SMB over network connection problem.
If I switch Wi-fi bands (between 2.4 GHz and 5 GHz), then I can reconnect to Vero 4k+. But I continue to lose the connection after a while.

Does your router/access point allow you to configure it such that you have different ssid’s for 2.4ghz and 5ghz?

Each channel (2.4 and 5.0) has a different SSID.
This did not happen before the last update.

We can’t change the SSID on your router.
Can you please explain the issue more clearly?

I connect to the Vero 4K+ over Wifi to do file management, to upload and delete files, with my Macbook using Finder using “Connect To Server” using SMB

In “the old days” when I lost connection to the server I merely had to reconnect and there were no problems.

After the last update, (the only change that has happened), I still lose SMB connection to the Vero server but now there is something new

If I am on the 2,4ghz wifi channel and I lose SMB connection via Finder and I try to reconnect on that channel/SSID it just hangs and I cannot reconnect.
If I change to the 5.0ghz channel and try to connect to the server then it works. But when I lose connection then I have to change the wifi to 2.4ghz and then I can connect.

The ideal solution would be not to lose SMB connection.

Maybe the problem is not with the Vero4K+ but this started happening only after the last update.

I’d suggest uploading some logs.

Does the network connection die on the Vero when this issue occurs or is it only the SMB connection?


I have no other network connectivity issues.
For now, forget about it.
If someone else mentions a similar problem, then we can go further.