Network problems

I have a newly christened Alpha 4 on a raspberry pi B. And I’m having sporadic network issues. I checked dmesg there is nothing, I checked the kodi logs and there are no errors other than not being able to reach the internet.

The issue is this my wifi is taking a while to come on. it used to come on very fast in RaspBMC. but now takes as long as 5 mins. and then it sometimes goes off again usually after I watch something. I don’t know what logs to check to see what the problem is. But in the system info the network would say Link: Connected but Internet: Busy or Not Connected. Check network settings. But if I went down to the console and ran connman, it would say that I’m connected.

So I would like to know if there are any other logs I can look at? Any reasonable advice will be greatly appreciated. Thanks!


Please post the output of dmesg so we can see what wireless chipset your adaptor uses:

dmesg | paste-log

Ahh, now dmesg comes up with something!

before it did not

I tried downloading firmware-realtek

Looks like the realtek site has updated drivers for my rtl8192cu

the firmware from the firmware-realtek and the wireless-firmware-osmc are the same.

16116 Jun 15 2014 rtl8192cufw_TMSC.bin

I upgraded my osmc (dist-upgrade) and that seems to have solved my problem. Now my wifi stays on.

Ooops, it’s still happening only a lot less often.


Please be patient. We are aware of issues with the rtl8192cu driver with some network adaptors and this is being worked on. (One of my own adaptors that uses this driver is likewise affected, so we are able to reproduce the problem in our own internal testing)

Fixing this problem will require an updated kernel so will probably will not happen until Alpha 5 is released.

Ok thanks.