Networking Problem

I just booted my new Vero 2 for the first time. I ordered the bluetooth dongle along with the device.

During setup configuration the network step already acted up; slow response time, wasn’t able to connect to the internet, pressing buttons didn’t do anything. Bluetooth wasn’t even displayed to be configured although I connected the dongle beforehand.

After some time I gave up and were able to go back to the main networking menu asking me if I want to configure manually or skip the step which I chose to get it over with.

But still the problem remains. The Network menu of My OSMC shows only Wired, Wireless, Tethering and MySQL. It takes about 15sec to switch between displaying the configuration stuff for each item in the menu. Bluetooth isn’t even displayed so I can’t even follow the simple guide on the wiki.

Twice the Bluetooth menu item was shown on the left. But seemingly every configuration options from all the networking menu items were displayed at the same time on top of each other. But selecting something in that case threw me back to the My OSMC menu.

Now after several reboots, editing /var/lib/connman/settings with
[Bluetooth] Enable=true Tethering=false,
trying sudo connmanctl enable bluetooth,
I have to give up on trying to fix this myself.

Network configuration is unfortunately something I’m not very good at.

Which logs would you be interested in? Or is there something I missed?

Where is the Bluetooth dongle plugged in?

What’s the output of

sudo apt-get update
sudo apt-get install usb-utils

On the side, the slot closest to the back.

Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 002: ID 2252:1037 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Doesn’t look like it is showing up there? USB configuration depends a bit based on the version you’re on

Is it detected in a PC?


On my Windows PC the dongle was successfully paired with my keyboard.


Try plugging it in a different port on v2

Run dmesg when you do and post the output


I removed the RF dongle of the remote and plugged the bluetooth in the back.

Edit: Looks to behave the same. No bluetooth menu item in network options. Slow response times in network options.


Will do my own testing with BT tomorrow on the latest OSMC for V2. Can you make sure you’re on the latest version?

The slow response in My OSMC is well documented, and is being worked on. It’s not exclusive to V2.

I did an update apt-get update, upgrade, dist-upgrade just prior to all that (I always hope updates fix problems for me :slight_smile: ).

Not related to your problem but just for the future save the “upgrade” step.

sudo apt-get update
sudo apt-get dist-upgrade

1 Like

Any update on the situation?

The slowness has been resolved. We’ll make this improvement available in the next update

I would normally say it’s a faulty dongle, but if it’s showing up on your PC, then that suggests it is not the case. I’ll dig around with the official BT dongle tomorrow morning and see if there have been any regressions.

Did you say that it did show up once in the menus before?



The menu did two or three times happen to show the bluetooth menu item, but it always disappeared again after a second or so, before I could even select it.

That’s really helpful.

It might mean a USB driver bug. Noticed a potential culprit in your logs.

[ 3035.071820] ERROR::dwc_otg_hcd_urb_enqueue:584: USB Connect status change processing

[ 3035.071832] Indeed it is in host mode hprt0 = 00021501
[ 3035.352105] Indeed it is in host mode hprt0 = 00021501
[ 3035.520547] Disconnect cb-Host
[ 3035.532053] usb 2-1: new full-speed USB device number 6 using dwc_otg
[ 3035.532167] ERROR::dwc_otg_hcd_urb_enqueue:578: Not connected

I’ll keep you updated