New 4K TV, can't set the resolution up


I’ve just got myself a 4K Sony Bravia KD55XE9005 and noticed that the resolution of my Vero was set to HD (Settings/System Settings/Display). I tried to manually change this to UHD but the screen went blank and I get a no input message, and the setting reverted to HD. So I dug around on here and I enabled Lock HDMI HPD in the same screen, and also enabled Adjust display refresh rate in Settings/Player Settings/Video but when I tried to play local 4K content the screen went blank with the no input message again. Weirdly if I went back in the menu with the film playing in the background it was clearly playing (with audio), albeit behind the menus.

I then removed my AVR (Denon 3310) from the equation and plugged the HDMI from the Vero to the TV and this worked. The HDMI I used is either the one supplied or one I got with an Amazon Fire, both of which should be able to cope with 4K. The output seemed to be 4K and when I went into the Display menu again the option to change the resolution was greyed out. However, when I reconnected everything (this involved an accidental of the Vero as I pulled the power cable out by mistake but I can’t remember if this was before or after changing the connection for the first time) everything now seems to be working and the same film is playing OK. Resolution settings are still greyed out but I’m not 100% sure it’s actually playing in 4K. I’ve been looking at it all for so long I’ve gone 4K blind and my brain is a bit frazzled. If so it might all be OK, but I’m now concerned that either my AVR can’t process 4K, or the HDMI from it to the TV isn’t compatible. I have no idea if either are, or aren’t.

I’ve spent a while trying to work this out but I’m now stumped. I guess my questions are as follows:

Would that reboot have been required to enable the two settings I’ve changed? If so, everything might be resolved.

Should the Denon be able to deal with 4K HDMI signals? It’s pretty old and probably pre-4K but I don’t know how this stuff is transmitted/decoded etc.

Would it be wise to change my HDMI cable from the AVR to the TV to one which I know is 4K compatible, as I have no idea if my current one is?

Thanks in advance.

Resolution should be set to 1080p. Kodi will then select the proper resolution for UHD, if the display is capable.

If you toggle HPD Lock, you need a reboot.
Power on Vero 4K last, with HPD option enabled and you shouldn’t have any issues.

Your manual probably mentions 1080p or 4K. If it doesn’t mention 4K, it’s too old unfortunately.

This cannot hurt.

If you still have issues, the next thing we will ask for are logs. These are very easy to upload and should let us know what’s happening.

Rest assured we should be able to get you up and running quite promptly.

Thanks for the quick replies. I can’t see any mention of 4K in the manual. It’s about 10 years old so I’m thinking it’s time for an upgrade. I’ll have another proper look tomorrow at the same movie with or without it connected and see how much difference in quality there is. I’m pretty sure with it in it’s only giving me 1080p resolution.

10 years old means no 4K support unfortunatly.


Looks like it’s going to be an expensive week then! :open_mouth:

Just checked this for you to make sure it definitely doesn’t do 4K before you fork out. It’s a 2009 era AVR so it’s a 1080p device.


Yeah I bit the bullet and bought a Denon AVR-X4400H and a new HDMI cable. I’ve just set it up and am still playing with it, but I’ve got an odd problem. When I switch the input to the Vero everything’s fine. However, when I play a locally stored movie the TV switches to HDMI4 (output to TV from the Denon is HDMI1 ARC). I can manually change it back so it’s workable but annoying. I’m sure I’ve just got a setting wrong, or something connected which I shouldn’t, but if anyone can see something blindingly obvious it might save me a load of playing around!

Disable Active Source under CEC settings.


Do you mean on the Vero? I’ve found System Settings/Input/Peripherals/CEC Adapter but I’m not sure whch setting, or device, you mean? I think CEC is called Bravia Sync on the Sony but there isn’t an option to just enable/disable active sources?

From the top of my head I think it’s called Set active source. Turning this off should fix things.

The setting should indeed be set on Vero

No setting like that as far as I can fathom, so I just disabled it completely. I’m not sure if this is what you mean? There is a setting called ‘Switch source to this device on startup’. Do you mean this? Either way it works as normal now.

I’ve also enabled the 10 bit settings on both the Denon and TV and the picture quality is noticeably improved. Is there a setting on the Vero for this or is it automatic. Thanks as always for your super-helpful responses :+1:

That’s the one.

There is, but this is only available via the command line. If you can wait a day or two, I can add an automatic option to enable this support via Kodi menus. I’d definitely appreciate some testers.


Well I’m stumped now! I’ve re-enabled that first CEC setting I disabled so I could check the second one and now the thing works OK so I’ve got no idea what I’ve done? Anyway, all appears to be working now. Yeah let me know if you need any help with testing etc. No doubt I’ll be tweaking and buggering about with it all for the rest of the week! :grin:

It’s possible you didn’t reboot after making the change.
CEC is also a little bit quirky, so it can play up. I suggest you make a note of your current settings and keep an eye on things.

I’ll ping you when HDR improvements are available.

HDR auto-switching is now available. After updating, you can enable this under Display.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Not sure the HDR auto-switching is working as intended. When played a none HDR file:-

osmc@osmc:~$ sudo cat /sys/class/amhdmitx/amhdmitx0/attr

However when I tried playing a HDR file, I’m getting the same thing and I can see banding etc, thus it’s no longer setting it to 10bit 4:4:4

Did you enable the HDR option under Display?
Post a debug log and MediaInfo if possible. I added logging for detection of BT2020, but may need to check further colour primary hints


I did yes, I’ve still got it set to add echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr in rc.local

I thought that would not be an issue since having a brief look at your code changes, it should be changing that value based on the media’s color primaries.

It’s clearly doing something because the value is changing from 444,10bit to reset when I play a non HDR file. It just does not seem to be going the other way.

Edit: I’ll post those logs and MediaInfo details soon.

Actually not sure why but removing that from rc.local and rebooting might have fixed it.

I can see it’s now changing to 444,10bit for HDR videos and "reset’ for everything else.
Is it meant to be showing reset or is that actually meant to just blank out the string for /sys/class/amhdmitx/amhdmitx0/attr ?

Edit: The plot thickens, it seems with some movies it only sometimes sets 444,10bit when you start it. Some movies always seem to work.