New Additional Settings for Drobo NAS

Hello - I have been using the following advancedsettings.xml file to help with buffering from my Drobo5N2 NAS that has worked perfectly until the Aug 19.1 update - here is the code:


Since the latest update my audio files buffer - can anyone tell me if the code or file location has changed and what I might need to do to fix it?

Thanks in advance!

Why would you need a non standard buffer config? What is the throughput of your network?

It’s a Gigabit network - Drobo is wired to Modem which is wired to OSMC. All I know is I experienced buffering issues with a previous Vero years ago that was solved the moment someone here suggested I use these settings in an advancedsettings.xml file. Years later, after upgrading to Vero4K+ and installing the latest update, my audio files stop and start to buffer, so I wondered if this was the cause.

Additionally, although unrelated to this ticket, one of my streaming radio stations at 128k also now buffers when previously they played perfectly and have done since I installed this update. Yet the other one @ 320k doesn’t. Go figure.

  1. Suggest to remove any manual buffer changes
  2. Check the connection between Vero and Drobo with iperf3

Maybe something changed in the network, we suggest to check your network with iperf3. Please read this howto

Thanks but although installing iPerf on my Vero was a piece of cake, doing that on my Drobo5N2 is too hard. Thanks anyway - I can almost bet that this problem will go away with future updates so I will wait for them.

I doubt that as no one has this problem how would a update solve it?

If it is too hard to install Iperf on the drobo install it on your PC to at least test between the Vero and your PC.

OK so testing network performance between OSMC wired to Modem then wireless 5Ghz to my PC upstairs about 15 metres away yields this throughput which should be more than enough by itself:

osmc@osmc:~$ iperf3 -R -c
Connecting to host, port 5201
Reverse mode, remote host is sending
[ 5] local port 59476 connected to port 5201
[ ID] Interval Transfer Bitrate
[ 5] 0.00-1.00 sec 24.1 MBytes 202 Mbits/sec
[ 5] 1.00-2.00 sec 27.2 MBytes 229 Mbits/sec
[ 5] 2.00-3.00 sec 27.8 MBytes 233 Mbits/sec
[ 5] 3.00-4.00 sec 27.7 MBytes 232 Mbits/sec
[ 5] 4.00-5.00 sec 27.2 MBytes 228 Mbits/sec
[ 5] 5.00-6.00 sec 27.5 MBytes 231 Mbits/sec
[ 5] 6.00-7.00 sec 27.8 MBytes 233 Mbits/sec
[ 5] 7.00-8.00 sec 27.8 MBytes 233 Mbits/sec
[ 5] 8.00-9.00 sec 27.9 MBytes 234 Mbits/sec
[ 5] 9.00-10.00 sec 27.7 MBytes 232 Mbits/sec

[ ID] Interval Transfer Bitrate
[ 5] 0.00-10.00 sec 273 MBytes 229 Mbits/sec sender
[ 5] 0.00-10.00 sec 273 MBytes 229 Mbits/sec receiver

So I’m certain wired to my NAS is much faster than this…

Looks good, if that are stable values and even better to the Drobo then surely no buffer changes needed.
So suggest removing any buffer settings and then upload debug enabled logs when seeing the issue.

OK will remove and revert accordingly…

I don’t know how your NAS exposes its files, but (if you aren’t already doing this) maybe mounting the remote share using autofs would speed things up?

OK, it appears the issue I was having after the update was in the System Settings/Audio section where my audio was previously set to Best Match. After applying the Aug 21 update, a couple of incoming radio streams (WFMU and 3RRR) and NAS access to my WAV files started constantly buffering.

Interestingly, the radio stream with the highest bit rate (True Vinyl Alternative@ 320kbps) did not buffer at all after the update.

I changed this setting to Fixed and set the highest bit rate and now both streaming stations and WAV files not only play uninterrupted, they but actually sound better than what I used previously.

Sorry to have bothered you all with this - I never would have guessed this was the issue, but I hope it helps anyone else having similar issues…