New broadband provider

I have a new broadband provider from this morning and now my 4K doesn’t appear to see the Internet? My internet is working on my pc and phone.
In settings info:
MAC address keeps changing to busy, otherwise the number matches router settings.
Network tab says either busy or not connected, check network settings.
Is the fault in the 4K or the new router?

Check My OSMC -> Network.
Are you connecting via WiFi or Ethernet?


Ethernet Sam

Take a photo of My OSMC -> Network -> Wired Ethernet settings.

I assume you have rebooted the device since plugging in the new router? The Vero may be using an old DHCP lease which could cause a conflict with other devices on your network.


In case you have the vero plugged in to your new router/modem … check the ports, on my modem not all ports are open for outside traffic

Sorry but I don’t know how to do that? I wondered if the Firewall on BT Hub is blocking things and what are the implications of switching it off? When I look at the Ports on the BT Hub Advanced settings it shows all Ports as DHCP other than the Vero Port which says Static?

We need to see the wired configuration screen from the MyOSMC add-on as Sam requested.

Is your new ISP using rather than

No but I notice the last number is a much smaller number than the other devices? I can give you the numbers if there are no security implications?


There are no security implications, as they private IPs, so yes please provide the addresses of the working numbers.

Also I would turn of the vero4k. And your PC using CMD:


If you get a reponse, this means another device is already using, try a different addess. I would try 100 or around that number, less chance of another device having that ip. (Or you check the DHCP range on your router) so:

Or try using dhcp see if it then connects to the network.

Thanks Tom.

I’m wondering if you’re dhcp pool needs changing so it starts with so any static ips are
Also does it connect if you use dhcp not static on the vero.
Switch between sky and plusnet every year havent experienced bt yet.

1 Like

You seem to have configured your Vero4K’s IP address manually. I suggest you choose “Configure Network Using DHCP” for now and see if that works. Reboot the device, just to be sure it picks up the new address.



I actually sorted the problem before seeing your suggestion but you were right and thank you. I’ll explain the whole chain of events and my thoughts as I think it may be useful information for all experts when trying to help other inexperienced uses like myself.

The first problem is that I am not familiar with the Vero 4K and from my point of view the screen shot I sent were the settings FOR DHCP because that is what it appears to say in the screen shot. The second problem was that if I clicked “configure network using dhcp”, the screen showed no settings and no means of inputting any (from my point of view). I then blamed the router (BT Hub) and tried to find how to change settings via the router. After a long time I suddenly wondered if clicking Apply, when in the screen that says, Configure Network Manually, would bring up a box that allowed me to input the ip address etc. Well you will know what happened next: the fields were filled in by the Router. Instantly! Sorted! If I known what I was doing, I could have sorted within 30 seconds of the problem occurring!

Sorry it’s taken a while to reply but I’ve had a very busy weekend with family stuff.

Thanks again everyone for your help - much appreciated.

Will see if we can find a way to make this clearer.
Glad it’s now all working well.



1 Like