New dongle/remote?

Happy New Year All,

I powered down/ unplugged original Vero to move to another room, and on reboot remote would not work. It is original remote (has scan buttons at bottom, not volume buttons)

I have replaced the battery and tried to re-pair using the below steps, but when I press the home and Ok button after 5 seconds the blue light stays constant and does not flash. And when I plug the USB back in, the blue light just goes out.

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

I have tried the USB in my PC and a laptop, and it is not recognised, so I am wondering is that the problem, and will I be needing a new dongle and matching remote?

On reboot I also get a message saying ‘Could not initialise Pulse Eight CEC adaptor’ but I do not use another remote with the Vero, so I am not sure if this is relevant.

Any advice would be appreciated.

Many Thanks,


That won’t be related (that’s a message about CEC).

Can you upload a log so we can see if the dongle is recognised on OSMC? Might also be worth showing us a photo so we can verify it’s the right dongle you are using.



Hi Sam, thanks for the quick reply.

Thought as much re the CEC message.

It’s the same dongle I’ve been using since I’ve had the Vero, and I’ve never had an issue.

The fact that the blue light doesn’t flash when I hold the home and Ok buttons down together for 5 seconds is something I have read about on the forums before.

I can try a wireless mouse to get the logs, but the USB dongle for that will be recognised in the logs. Let me know if these are OK.

Thanks Sam.

Logs created using kodi remote app, only Vero dongle inserted


Looks like the dongle is indeed not recognised.

Unfortunately we don’t produce this model of remote and dongle anymore, otherwise I would send you a new dongle free of charge


No worries Sam, thanks for your time. Much appreciated.


But you can find the new remote control in the shop, see menu item on top. :wink:

Already looking !! :grinning:

Have you tried it in both USB ports?

(The white USB port issue has since been fixed) — will not affect this customer’s device as it is a 4K.