New DVB-T tuner didn't find tv channels

I have new Vero4k+ with DVB-T tuner from, in dmesg I found:

[    3.036935] usb 1-1: Product: dvbt2
[    3.036940] usb 1-1: Manufacturer: astrometadvbt2
[    4.242957] usb 1-1: dvb_usb_v2: found a 'OSMC Engineering DVB-T2' in warm state
[    4.330145] usb 1-1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[    4.330182] dvbdev: DVB: registering new adapter (OSMC Engineering DVB-T2)
[    4.331260] dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.
[    4.403707] i2c i2c-1: cxd2841er_attach(): attaching CXD2837ER DVB-C/T/T2 frontend
[    4.403733] usb 1-1: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[    4.403756] dvbdev: dvb_create_media_entity: media entity 'Realtek RTL2832 (DVB-T)' registered.
[    4.403906] usb 1-1: DVB: registering adapter 0 frontend 1 (Sony CXD2837ER DVB-T/T2/C demodulator)...
[    4.403921] dvbdev: dvb_create_media_entity: media entity 'Sony CXD2837ER DVB-T/T2/C demodulator' registered.
[    4.508756] rc rc1: OSMC Engineering DVB-T2 as /devices/c9000000.dwc3/
[    4.508984] input: OSMC Engineering DVB-T2 as /devices/c9000000.dwc3/
[    4.511545] rc rc1: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 1
[    4.511561] usb 1-1: dvb_usb_v2: schedule remote query interval to 200 msecs
[    4.520249] usb 1-1: dvb_usb_v2: 'OSMC Engineering DVB-T2' successfully initialized and connected
[    4.520376] usbcore: registered new interface driver dvb_usb_rtl28xxu
[   19.823634] usb 1-1: DVB: adapter 0 frontend 0 frequency 0 out of range (174000000..862000000)

TvHeadend found only 2 muxes with total of 8 channels. So I tried another tuner (bought 2 years ago from too):

[    4.303444] usb 1-1: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[    4.303467] dvbdev: dvb_create_media_entity: media entity 'Realtek RTL2832 (DVB-T)' registered.
[    4.303624] usb 1-1: DVB: registering adapter 0 frontend 1 (Panasonic MN88473)...
[    4.303639] dvbdev: dvb_create_media_entity: media entity 'Panasonic MN88473' registered.

And now 63 channels found with exactly the same settings. Is the new one bad piece or has just low gain/sensitivity?
I tried both tuners plugged directly to antena and through splitter but it had no effect.


BTW: What to create DVB-T forum category?

Maybe the signal is not strong enough.
Is anything else connected to USB?

Yes, it seems that signal is strong enough for old tuner but isn’t for the new one :frowning:

I tried scanning with tuner attached

  • directly to vero (2nd usb port used by remote control receiver)
  • indirectly through powered usb hub
    (in this case together with wireless keyboard receiver)

but no difference observed.

The signal may be marginal. Is there a way you can improve this and try again?

Hello Sam,
you are right - I just installed ubuntu 19.10 + tvheadend on my pc and tuner works fine!
I will experiment with it on weekend.

1 Like

Solved: After removing /home/osmc/.hts and reinstallation of tvheadend package “Sony” tuner was found together with “Realtek” and 65 channels found.

I probably forgot to clean .hts after switching tuners.