New episodes of existing TV Shows not showing

I have an odd issue, that I would appreciate some assistance with.

My TV Show library, when I scan for new content, it is not picking up on new tv show episodes added to an existing tv show.

It’s also not picking up on newly added seasons, where the previous seasons are in the library.

I have restarted, done updates, also rebooted the synology nas that is holding all the content.

If I manually select refresh all information for this tv show, it removes the show completely from the library. This happens if I select either use local info or use the internet info.

These issues are not happening with the Movies side of Kodi, where new movies are found and added perfectly.

I can still find these new episodes via the: Videos path.

Any thoughts appreciated. thanks

I would make sure that in the library when you bring out the side menu it has “all videos” shown and not “watched” or “unwatch” just in case that is the reason why they disappear. A typical reason why new episodes don’t get picked up is because a scraper was changed without refreshing the show. Basically the way it works is when your TV show is added to the library it gets set with a location of where to get the metadata from. When it scans the library it only reads season and episode data from the files and uses the location already in the database as the source for where to get the episode details. When a show is initially set to use, for example, TVDB but the scraper gets set to TMDB later no new information can get picked up since the show is no longer pointed to a valid source. When you refresh a show (the show itself, not an episode) it updates the scraping source which normally fixes the issue.

If the above doesn’t lead you to a solution then I would suggest to reboot twice, refresh one of the problematic shows, and then upload logs and let us know what the url to these logs are to gain a bit more insight.


I think you are on the right track with the Scrapers.
One was recently discontinued.
I did a series of moving the shows out of the TV Show folder, cleaning library, moving back and scanning for new content.
None of them appeared.
I have also noticed that entirely new downloaded shows are not turning up either.
I disabled the old scraper. Also downloaded a new one and tried again.
No change.
I have a log file here:

Appreciate your thoughts.

It looks like your using a old TMDB scraper that is listed as broken. Try switching over to “TMDB TV Shows” v1.6.5.

Also not all of your movie are scraping so you might want to give the “Missing Movies” add-on a try to help you find which ones. I happened to notice “Break Nights” being one of them. The issue with that one is that you have it titled with 2017 but TMDB, which is what you’re using to scrape it, has it listed in 2018 (even though IMDB says 2017). This is an annoyingly common thing I run into as well. I would recommend to either rename it or use a nfo (or parsing nfo). You could always just manually match in Kodi but this becomes a headache if you have to redo your library in the future.

And also your NAS makes extra folders which Kodi is picking up on and slowing you down as well as spamming the logs a bit. You can find a fix for that here…

Thank you both. Very helpful.

Resolved, and this is what I did if it assists anyone else in the future.

I installed TVDB TV Shows v1.6.5
I disabled the other scrapers.

Shows were not showing still…

I installed and used Missing Movies, and tidied up as suggested.
This also showed me clearly which TV Shows were not being found.

I went into Videos, clicked on one of the missing shows, selected ‘Change Content’ , then changed it from the old scraper to TVDB TV Shows v1.6.5

Rescanned the library.

The missing episodes and shows were found.

This resolved the issues for me.

Appreciate the advice and support!