New install on USB doesn't seem to use USB for storage

Hello,

I’ve installed OSMC on a USB drive via the Windows Installer. After booting the Raspberry Pi3 the USB stick is formatted during the install process.

After KODI is installed I noticed that my home directory is still on the SDCard. I was excepting this to be on the USB drive. (I’ve copied a large file to my home directory and the command df shows that the available space on my SD card is decreased)

Is this a know problem, or is it designed to work like this? If it is designed to work like this, then when is the USB drive being used?

You need to install OSMC on the SD card enabling the USB option.
Then boot with USB inserted.

The bootloader and kernel must remain on the SD card.

I have started the PI with the USB drive inserted.

How can I enable the USB option?

My df output :

Filesystem 1K-blocks Used Available Use% Mounted on
devtmpfs 369672 0 369672 0% /dev
tmpfs 374792 9856 364936 3% /run
/dev/mmcblk0p2 3498368 2645500 655444 81% /
tmpfs 374792 0 374792 0% /dev/shm
tmpfs 5120 0 5120 0% /run/lock
tmpfs 374792 0 374792 0% /sys/fs/cgroup
/dev/mmcblk0p1 244988 22202 222786 10% /boot
/dev/sda2 59607260 7720128 49402848 14% /media/b4ea8e46-fe87-4ddd-9e94-506c37005ac5
/dev/sda1 42137 21474 20663 51% /media/boot
tmpfs 74960 0 74960 0% /run/user/1000

You need to do it when you install OSMC.

I have started the PI with both the freshley created SDCard and the USB drive.

You need to reinstall OSMC.

It’s covered here: http://www.averagemanvsraspberrypi.com/2015/10/install-osmc-on-a-usb-stick.html

I have followed those instructions step by step.

It used to work in the past, but if you try it now, you will see for yourself that it is not working any more.

I think something is wrong with the installer.

There’s an install.log file on the SD card which should show what has happened.

This is the content of the installatie.log. IT looks like it didn’t find the USB drive sturing install.

Thu Jan 1 00:00:07 1970 Starting OSMC installer
Thu Jan 1 00:00:14 1970 Detecting device we are running on
Thu Jan 1 00:00:14 1970 Mounting boot filesystem
Thu Jan 1 00:00:14 1970 Trying to mount to MNT_BOOT (/mnt/boot)
Thu Jan 1 00:00:14 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32
Thu Jan 1 00:00:14 1970 No preseed file was foundThu Jan 1 00:00:14 1970 Creating root partition
Thu Jan 1 00:00:14 1970 From a root partition of /dev/mmcblk0p2, I have deduced a base device of /dev/mmcblk0
Thu Jan 1 00:00:14 1970 Determined 255 MB as end of first partition
Thu Jan 1 00:00:14 1970 Calling mkpart for device: /dev/mmcblk0 and fs: ext4 with start 257M and end 100%
Thu Jan 1 00:00:16 1970 Calling fmtpart for partition /dev/mmcblk0p2 and fstype ext4
Thu Jan 1 00:00:37 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
226688 inodes, 905216 blocks
45260 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=926941184
28 block groups
32768 blocks per group, 32768 fragments per group8096 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736

Allocating group tables: done
Writing inode tables: done
Creating journal (16384 blocks): done
Writing superblocks and filesystem accounting information: done

Thu Jan 1 00:00:37 1970 Mounting root
Thu Jan 1 00:00:37 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:00:37 1970 Using device->root: /dev/mmcblk0p2
Thu Jan 1 00:00:38 1970 Extracting files to root filesystem
Thu Jan 1 00:00:38 1970 Starting extract progress…
Thu Jan 1 00:05:51 1970 Extraction of root filesystem completed
Thu Jan 1 00:05:51 1970 Configuring bootloader
Thu Jan 1 00:05:51 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:05:53 1970 Configuring boot cmdline
Thu Jan 1 00:05:53 1970 Configuring /etc/fstab
Thu Jan 1 00:05:53 1970 Successful installation. Dumping log and rebooting system

This means you didn’t enable the USB option in the installer.

Today I have tried for the 3rd time to install OSMC onto an USB stick. I tripple checked that I have selected the USB option, but after starting and going to the whole setup process I end up with the same situation. The USB drive is only used as media, and not as Root.

Then I tried it with another USB disk, and to my surprise it showed me that it was going to install on the USB device in 60 seconds. I swapped out the USB disk for the 64 Gb Ultra Fit and all is working as expected.

Looks like some USB devices require more time than others.

Is there an option I can insert into the cmbline.txt or in the config.txt?

Also looks like the “preseed” message in the install.log is wrong. When it can’t find a suitable USB, it writes the wrong info into the logfile.txt…

Mechanical drives are usually the slowest but we don’t tend to get problems with those.

Make sure you don’t have any SanDisk software like U3.

The USB drive was reformatted and had no software like U3 on it. Just plain FAT32.

The installer has an option for debugging, but you’d need to set up a netcat shell and build it from source.

It takes a few seconds to start the installer and we wait for udevadm settle, so I am surprised that the disk isn’t ready in time.

After reinstalling another Raspberry Pi with OSMC I found the real problem.

If you remove all partitions from the SDCard, the Windows installer only copies the normal install files over to the SDCard, but it never copies the preseed.cfg. Maybe because the SD-Card does not has a drive letter assigned to it.

If you first format the SDCard as FAT or FAT32 and then use the Windows installer, the preseed.cfg file is created and the install process works like it should.

So it looks like the Windows installer program needs some work, or inform the user he first needs to format the SDCard as FAT or FAT32.

The image that is written contains a FAT32 partition and thus Windows should assign a drive letter by default.