New modem and now I have no internet connection

I apologize in advance, not the most tech savvy individual.

I just updated my internet with Shaw, they gave me a new modem (Hitron), just spent a half hour with their customer support trying to get everything connected since it would only connect with 1 device via wifi at a time and no wired connections were working.

I thought we got everything fixed but I now noticed I can’t stream anything with my raspberry pi, I have a wired connection but it won’t let me configure using DHCP it just constantly kicks it back to manual input. I’ve tried changing the cables and using different ports. I’ve read previous posts about people pinging and I’m clueless on where to even start with that, closest thing I know about Ping is I have a set of irons in my golf bag. I’m not sure how to look up my IP address to try a manual input, I’m just lost…

Hoping someone here takes alil pity on me and can help me figure this out, thank you in advance.

Hi, and welcome to hell :stuck_out_tongue:
Ok first thing…is your PC getting internet from the router? Any device at all ? Which (1 device) gets internet ?
Do you know your router’s local IP address ? (ex: 192.168.1.1)
If you do, then on the pi/pc/any other device you have in the house, you have to set up static ip addresses.
What IPs to set up ? Any incremental value above your router’s ip address (ex: pc: 192.168.1.2, pi: 192.168.13, etc)
For Local subnet mask set: 255.255.255.0
And for DNS you put your router’s local ip address (ex: 192.168.1.1).

To see what IP address your PC has, you open up a CMD and type ipconfig.

A ‘trick’ that i do so i dont have conflict with my DHCP server…is on the router page, i set up the DCHP server to start giving automatic ips from a range of 192.168.1.50 and up…So i set up all my devices in the house bellow that number, and any friend coming with a laptop or something will get an ip above .50…so no conflicts.

Using static ips should temporarily fix the problem you are facing, but i would return the router back for service since you cant get automatic ips from it.

Thanks for responding to my cries of help.
After spending all night with Shaw tech support to get everything set up I come home from work to find I’m having the same issues as last night again. Going to return this router and get a new one and see if that will fix my issues.
Again thanks for responding and I’ll keep ya posted on how the new router works out and if I need to start this process over again.

Alright, the new router is working a lot smoother then the last one but my pi2 still won’t connect. When I go to system info here’s what it shows me.
Link:Connected
Mac Address: B8.27.####
IP Address:169.254.#####
Subnet Mask:255.255.0.0
Gateway:
Internet: Not Connected. Check network settings.

Looks to me like the DHCP is working and supplying an IP now, just not sure where to go from here.

This ip range (169.254…) is not real…its a windows thing, meaning it cant reach the dhcp server ( http://packetlife.net/blog/2008/sep/24/169-254-0-0-addresses-explained/ )

You should set up a static ip the way i said earlier in my post.
Find your router’s ip address (should be 10.0.0.1 or something like 192.168.1.1…You probably know it already…its the address you put on your browser to connect to your router’s web admin page), then increment a few numbers and set your pi to that ip (ex: 192.168.1.10), with subnet mask 255.255.255.0 and both gateway and dns1 to your router’s IP address.

You are my hero, thank you very much. All the help was greatly appreciated.

No problem. Did it work ? Unfortunately you’ll have to set up static ips like this for all of your devices at home.

I did get it working, still having little issues connecting devices tho. Seems like the router will only give 1 or 2 devices an ip address and everything else won’t connect afterwards. I’m thinking I might try what you suggested earlier and set static ips for my devices and set the router to give ips starting a higher placement…is that the right word?

Yeah, ‘range’ is a proper one since it gives IPs from .1-255.
The reason behind this ‘trick’ is because, lets just say your pi has a static IP of 192.168.1.2, the next available IP in the range…but for some reasons its off for a few days…and during that time you connected to your router with your laptop and the DHCP gave your laptop the next available ip which is 192.168.1.2 since thats the number it starts from. When you fire up your pi, there will be an ip conflict…since 2 machines will try and have the same local ip.
So to prevent this from ever happening…all your devices have a static ip (1.2, .1.3, .1.4 etc) and you set the dhcp to start from .1.10…All new devices will never have a conflict with the other ones.

Most routers have a ‘grace period’ usually 2-3 days, where they hold an ip if a machine is offline…so they wont give it to the next device that connects…but nonetheless setting your dhcp like i said will avoid any future conflicts