New movies won't show up


Would really appreciate some help, as I bought a Vero 4K+ as a gift for the Holidays and still can’t seem to make it work.

In my Vero is a 256GB card, which is used to store the movies I upload from my computer over SSH with SCP.

The first movies I uploaded can be found in the Movies section with nice titles, posters, summaries, etc. So far so good.

All the other movies I uploaded after that, however, never showed up. They are only seen when browsing the files, but they don’t have posters or anything, and their titles are just their folder names.

According to my settings, the library should be updated on boot, but restarting the Vero doesn’t seem to do anything.

After going through all the menus and settings so many times for the past month, I would really appreciate some help.

Thank you reading, have a beautiful day!

KODI itself is probably the best resource, for example how to manage a library is here:

In simple terms try to ensure the filename has the full film name and year of release, preferably in it’s own folder with the same naming convention.

Try if you can’t find what the “correct” name is for a film.

I did read these pages and configured everything, including the scraper, but none of the movies I’m uploading are being properly added like the first ones were.

Each movie is already in its own folder, and all folder names include the movie title and its year of release. Just like the ones that were properly scrapped and added to the library at the beginning, hence why I don’t understand why the new ones aren’t recognized.

Also did that, and can confirm that all the movies not being scraped are present on the website with the same names and years.

Just redid a complete tour of all menus and settings, and it’s still a mystery to me. :frowning:

Are you actually asking the Vero to update the library or are you expecting it to happen automatically? I would normally go into my movies library, then go left to pop out the side menu and then click update library.

If manually updating the library like jb2cool described doesn’t do the trick then you would really need to provide some logs to give us something to work from. Ideally this would include rebooting your device twice, then turn on debug logging, then to a library update, and then upload logs making a note of the url that is returned. At this point you can turn off debug logging and post that url in this thread.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

According to my settings, the library should be automatically updated on startup. When I realized that wasn’t working, I did try to update it manually just like you said—many times—but it doesn’t seem to do anything. :frowning:

Sorry, I totally should’ve provided logs from the beginning. Thank you for explaining how to do so, it helped! Here’s the link:

If you could find the time to look into it, I would really appreciate it!

Thank you. :slight_smile:

It appears from these logs that you never actually configured any sources. Make sure that the files you copied over to this SD card are sorted in different folders based on content type. Typical may be having something like folders labeled “movies”, “series”, and “music” (the actual label is not important, only that content is separated and not nested). At this point you need to go to videos>files>add videos>browse> and then navigate to one of these folders (ie root>media>movies) and then OK then configure the rest of the settings as they come up. You will repeat this for every source file location you want to configure. If at some point you need to tweak your scraping settings then just videos>files>highlight the source you want to edit>context menu>change content.

This is what I did when setting everything up last month, but I probably made a mistake somehow. Started anew, redid everything, and it’s now working like a charm!

Thank you so much for your help, I really appreciate it. :blush:

1 Like