New network woes

For the longest time, I had my Vero4K working fine. However, I just changed ISP’s and the new modem/router I was given seems to have upset the whole network. I’ve managed to get everything working except my Vero.

I have the modem/router from my ISP which has wifi built in. Via ethernet, it is connected to an Asus router in my basement. There is another Asus router in the attic which is part of a wireless AIMesh with the basement router. Let’s call the ISP’s router’s wifi network “wifi” and the AIMesh is called “wifi_RPT”

I have TV/movie files on my NAS which is plugged in to the basement router. The NAS is set to have a static IP of

Before the switch to the new ISP, everything on my network was 192.168.1.xx - this new one is 192.168.2.xx. I am not a networking expert, but this change seems to be creating havoc. Now, my Vero is understandably trying to find files in the old NAS location. I can’t find an easy way of changing IP from 1 to 2 in the Vero. When I try and go and try to point to the Movie library to the new location, the Vero just hangs.

I have also tried to set the network address of the Vero to be static, except it doesn’t stay and keeps changing to what, presumably, the ISP router is assigning to it.

If I’m missing any info to help figure this out, please let me know. Setting up my Vero with all the video files and live tv and PVR was very painful and I really don’t want to do that again if I can help it.

edit: added some more info

This can be fixed, but the quickest way would be to change the IP range on the router, and it may be configurable.

Have you checked if that’s possible?

I have managed to get the Vero to stick to However, the movies and TV shows are not there. They are listed, but if you go into a show, it just shows nothing.

I am trying to browse for a new share to get the Vero to point to the new NAS location, but as soon as I choose browse NFS, the Vero hangs and I have to unplug it to get it back. I also tried directly typing in the NFS:// path in, but it still hangs.

You would need to change all sources and you need to either rescrape your database or configure a path substitution.

The recommendation is still to change your LAN in your new router to 192.168.1.x (should be easily).

If you insists to stay with your 192.168.2.x range the easiest would be to update on the command line. For us to help you would be good to upload logs with either MyOSMC -> Upload Logs or on command line grab-logs -A and share the URL

I haven’t tried changing my new routers IP - the provider says it should remain as a 2, though doesn’t really explain why.

Anyway, I did the typing in the direct path to the NAS and left it for a good 20 minutes or more and it found it. I have now clicked on ok and it appears to have hung again, but came back after 10 minute or so.

Log is at

Well then go down the painful path.

Access the Vero via command line

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

  1. Stop Mediacenter sudo systemctl stop mediacenter
  2. Edit sources.list nano ~/.kodi/userdata/sources.xml and replace all entries of 192.168.1 with 192.168.2
  3. Configure path substitution, best to review the [HowTo] Repairing File Paths with Path Substitution on that but basically you want something like
  1. Start Mediacenter sudo systemctl start mediacenter

If you follow the howto I linked this step might be discouraged and you could/should skip this change.

1 Like

Thank you for this information.

I’m starting to think that it might be a WiFi issue. I have a smart tv (to which the Vero is connected).

If I wirelessly connect the TV to the ISP’s router and run a speedtest, I get about 100Mbps. If I connect the Vero to the same, I get a pathetic 4Mbps. I think things might be working, but at such an incredibly slow speed that the Vero seems to hang all the time.

Is the Vero WiFi known to be not so great?

Well first in regards to the database (not about changing the sources) that surely will be impacted by the IP address change and can only be fixed by either a rescrape or the path substitution.

But yes 4 Mbps wifi indicate something is wrong. In normal environments the Vero4k Wifi should perform much better.

  1. Do you have 5ghz and 2.4Ghz with separate SSID? Otherwise the Vero might be connected only to 2.4Ghz
  2. Has something else changed recently? Could you temporarily try with Ethernet?

Check this

Maybe something changed in the network, we suggest to check your network with iperf3. Please read this howto

I can’t even log in using Putty. I don’t know which port to use, but it is defaulting to 22 and I get this result (I have the correct password):

:bust_in_silhouette: Starting a new connection to: “” port “22”
:gear: Starting address resolution of “”
:gear: Address resolution finished
:gear: Connecting to “” port “22”
:bust_in_silhouette: Connection to “” established
:gear: Starting SSH session
:gear: Remote server: SSH-2.0-OpenSSH_7.9p1 Debian-10+deb10u2
:gear: Agreed KEX algorithm: ecdh-sha2-nistp256
:gear: Agreed Host Key algorithm: ssh-rsa
:gear: Agreed server-to-client cipher: aes128-ctr MAC: hmac-sha2-256
:gear: Agreed client-to-server cipher: aes128-ctr MAC: hmac-sha2-256
:gear: Agreed client-to-server compression: none
:gear: Agreed server-to-client compression: none
:gear: Handshake finished
:bust_in_silhouette: Checking host key: 54:24:d0:2a:bd:63:fb:f5:30:ef:39:22:c1:97:88:24
:bust_in_silhouette: Host “”:“22” is known and matches
:bust_in_silhouette: Authenticating to “”:“22” as “osmc”
:exclamation: Disabling authentication using publickey: Private Key is empty
:gear: Available client authentication methods: password,keyboard-interactive
:gear: Authentication that can continue: publickey,password
:bust_in_silhouette: Authenticating using password method
:exclamation: Authentication failed (password)
:gear: Partial success: no
:gear: Authentication that can continue: publickey,password
:bust_in_silhouette: Authenticating using password method
:fearful: Connection to “” closed with error: end of file

I have also noticed that when I have to reboot my Vero by unplugging it, there is some text on the blue boot screen that was never there before. I can’t make out the top line.

Have you tried directly on the Console?

I have now hooked up the Vero to the network via ethernet and running the speed test on Vero gives acceptable results, so any further errors are not because of network speeds.

I’m sorry, I don’t what you mean by this.

The errors in my previous message were when I used a terminal program on an Android tablet to connect.

I am now at my computer which is, through an ethernet network, attached to the Vero via Putty. Putty gave an error about something to do with SHA and how this device might not be the computer I think it is. Unfortunately, I didn’t really note the error and chose to “ignore the error in the future” so I can’t reproduce it. I proceeded anyway and appeared to log on.

However, every few minutes, the Putty screen will start rapidly scrolling showing this:

Broadcast message from root@Vero4K (Thu 2022-07-07 09:56:43 EDT):

Password entry required for ‘Enter Auth Password:’ (PID 15348).
Please enter password with the systemd-tty-ask-password-agent tool:

Broadcast message from root@Vero4K (Thu 2022-07-07 09:56:43 EDT):

Password entry required for ‘Enter Auth Password:’ (PID 15347).
Please enter password with the systemd-tty-ask-password-agent tool:

Broadcast message from root@Vero4K (Thu 2022-07-07 09:56:43 EDT):

Password entry required for ‘Enter Auth Password:’ (PID 15346).
Please enter password with the systemd-tty-ask-password-agent tool:

These lines repeat beyond the Putty window and then it just stops for a while and I can type in more commands, then it starts scrolling again with the same password entry required notification. If I do nothing and just watch the Putty window, every so often this rapid series of notifications will happen again.

Based on something I saw in your logs that seems to be related to the openvpn/tor solution you installed. Maybe try to uninstall what you have installed with openvpn.

This could be related that before you were connecting to a different system under that IP but could also mean that the SSH keys IDs were changed.

I can’t seem to uninstall it, at least not from within Kodi and I don’t know how to from the command line.

What I’ve tried: FYI I’m using the osmc skin so I can see everything

Gone into Programs, there is nothing VPN related there

Went to Settings → Add on Browser and there was something like VPN manager, but it was disabled. To be safe, I deleted it.

Went to My OSMC and looked under network and services. Nothing VPN related there. I can’t think of anywhere else to look.

Now, when I reboot the device, I get this which stays on the screen for about 60 seconds

Then it goes to the blue boot screen and again I have this:

It’s difficult to read, but the cut off line at the top makes some sort of reference to a VPN. I can’t make it out precisely.

So, something VPN related is still happening, but I am unable to figure out how to delete it.

FYI, this is the error I am getting when trying to log into the Vero from a computer elsewhere on the network:

Ok, that is normal if you haven’t connected to it before on that device. Onetime saying yes and then it should not appear again.

Not sure if you followed a tutorial to install it? If we know how you installed it we might better know how to uninstall it. But to be honest maybe you are now at a point where a clean reinstall would be best.

This shouldn’t be, check overscan settings

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

I’m fairly sure I for it from here, but I’m unclear on how to uninstall it.

I’m close to staying from scratch, but think that maybe getting rid of this VPN stuff might be the key

I think starting from scratch might be the easiest at this moment

Well, in the end, I think my Vero stopping working and my getting a new ISP may have been an unfortunate coincidence. Eventually I couldn’t log on via Putty and the device basically stopped working, so I’ve wiped it clean and am going through the process of rebuilding it. The movies and TV shows are relatively painless, but getting the PVR to work is another story.

At any rate, thanks for the help.

1 Like