New OSMC can't see my SMB network drives

I’m the happy owner of four Raspberry PI 3 Model B.
I have just purchased number 4.
I did the same for installation for device number 4, as I did for the three first ones.

Using OSMC-Installer for Windows to write image to SD card. Setup is network by cable.

But I have an issue.
The new installation simply can’t see my SMB network shares.
If I type in IP, path, user name and password, all files is shown in file list, but they all have size 0 bytes.

I can see that the device is connected to my network because I can see it in my DHCP table, I can access the web interface by my PC, and by looking into setting I can see IP, Gateway and DNS IP’s

If I use a pre-installed SD-card (One from my already existing Pi’s) in the device, everything works fine.
I tried, replace the SD card with a new one, same issue.
Tried with another Raspberry PI, same issue.
Tried other network location, same issue.
Tried to switch to wifi network, same issue.

It is simply like there is something wrong with the newest build of OSMC Kodi 2017.04-1 for Raspberry PI 3 Model B.

Kind regards,

Hi Søren,

logs showing the issue would probably help.

Also 2017.04-1 is not the latest release, please update via myosmc and see if the issue persists.

Thanks Tom.

Hi Tom.

Thanks for your answer.
I upgraded to newest version within OSMC. Still same issue.
I’ll post the log tomorrow. It’s getting late here in Denmark.

Thanks for your help.

Kodi has had issues adding smb drives forever, sometimes it works and sometimes it doesn’t. Easiest solution is to manually edit sources.xml or easier copy /userdata/sources.xml and passwords.xml from another working install.

Maybe this change to smb.conf helps? Would be strange though because the other installations work fine.

Well I found a workaround for my issue.
My Pi3 still can’t browse my network and see my SMB shares.
But I can type in the server, path, username and password and it works.
I just have to remember that paths is case sensitiv.

A search in this forum, shows that I’m not the only one, having this issue.
So maybe there will be a fix soon, I hope…

I use SMB share from windows 10 whitout any problems… my account has not “case sensitive” letters but i have a @ on username…

Otherwise on preferences of “Sharing network” on Windows 10 you need to disable the sharing by password and all works whitout any problems but on osmc you still need to put your windows access.
Also for folder you want to share you need to Add “Everyone” for access write/read…