New OSMC Volume at100% won't change from remote

Kodi can be fully controlled without those keys (the direction keys duplicate those functions) but if you want those keys and everything to work without any kind of a strange setup I would highly recommend just using a universal remote and program it for the Sony TV. Even though your original remote may have been missing those extra keys the TV should most likely respond to an extended keymap. Unless the TV is really old you should also be able to just setup the thing with CEC (the flirc would not be needed) and all the controls would run through the TV with only needing a stock OSMC setup.

My TV here in the summer house is 10+ years and the one at home 12+ years old. Both Sony BRAVIA (40" and 37")…

Anyway I think I am on to what is causing my problems now!
I Googled and found this post regarding inability to use FLIRC with French language.
It seems like the system language of the OSMC box affects how the remote codes are interpreted! What I need for the volume is the char + for increasing and - for decreasing the volume. When programming these using the FLIRC configuration program and you use the Kodi profile the configurator assumes a US-English locale and programs the HID keycode like how these keys are placed on a US keyboard. This will work if the system language on OSMC is English, but on Swedish locales these keys are on different keyboard buttons and so the OSMC system interprets them differently than expected…
I tested by using the “Full keyboard” profile in the FLIRC configurator and selecting the key that holds the + and - keys on a Swedish keyboard when programming the remote interpretation. Notice that the configurator shows the US keyboard in this situation.
After I had done the new programming late last night, then the volume keys started to work as expected!

My problem is that on my OSMC (the new one) I had to enable the Swedish keyboard inside the terminal window without changing the system language. But I failed, I got both…
So my OSMC is now on Swedish locale whereas my old OSMC is on English but with Swedish keyboard enabled. Hence the differences in behaviour.

I noticed the language change when I issued some misspelled commands inside the terminal on the new OSMC and the error message came out as Swedish!

So can someone please direct me to how I can change back to English as system language while keeping the keyboard as the Swedish layout?

I thought you wanted åäö in console too, that’s why i recommended the locales change.

try this:
sudo nano /etc/default/locale

either comment (# in the beginning) the lang row containing se.something or remove the row completely (CTRL+k)

This would solve, system in english but still swedish keyboard layout

Well, after the edit and a reboot it returned the system to default (English) language concerning the messages in a terminal. But also regarding keyboard entry, so no åäö, which is not really important, but all the other special characters like /+?}][{ etc are now impossible to find…
So in this situation it is nay impossible to edit scripts etc in a PuTTY terminal.

There must be some other similar file to edit to get back the Swedish keyboard as entry method while keeping the English language.

strange, clean install of OSMC i got the / at shift 7 in putty (no åäö in console)

OK I was too early stating the key failures…
Now checking the keyboard into PuTTY on the new OSMC and the result is this:
All keys produce the correct display except:
Shft-4 å ö ä Å Ö Ä £ ½ §

So contrary to what I wrote the chars needed for coding scripts etc do work using AltGr as shift key.
But the Swedish chars are non-working.
On my old OSMC box it is much the same except for a few keys that also do not work but in a different way (the last 3 in my list above).

fwiw, when i updated osmc a couple of months ago, some of my settings went haywire.

the symptom was that the sound level dropped, a lot. normally, i have my cable box set at max, and then i adjust the volume on the tv. but after the update, i had to crank the tv to 100% and the audio was still a bit too soft. needless to say, this was a problem when i switched to the other input. but i couldn’t find any settings for playback volume on the pi.

the source of the problem turned out to be my “remote” settings in osmc. the update had knocked out my samsung tv remote, and reverted back to a generic controller, so i couldn’t get access to the volume control inside the media player. the “enter” key wasn’t being an enter key.

once i reset the controller type, i had no problem getting to the volume control (inside the media player), and turning it up. but that was only after hours of poking around in osmc, and lots of googling. because it really wasn’t obvious.

good luck!

Thanks for the info, so I am not alone then!

I am now back to not having a working volume control on my remote…
What I do is I program the FLIRC receiver using their config software on my Win7 machine and then I put + as Volume-up and - as Volume-down.
I can verify in an editor inside Windows that these characters are being received when I press the volume key.
But when I move the FLIRC receiver back to the OSMC (RPi2) box then using Vol-up makes it go down! And Vol-down does exactly nothing!

I have even purchased a “universal” remote and programmed it from scratch and it still won’t accept the volume key functions. Unfortunately there are also other issues with this remote since it does not send out anything for certain keys. Without anything being sent FLIRC cannot translate into the proper Kodi code…

Could you please tell me what exactly you did to tweak the key interpretation inside OSMC? Is there a config file where one can define the keys that should be used for vol up/down???

If you have a universal remote now then leave the volume in Kodi at 100% and program the universal remote to adjust the volume on your TV instead. Any universal worth having allows for the volume keys to be fixed to a TV or AVR independent of the rest of the keys. As for the control of everything else I would program the universal as a MCE (RC6) remote and then program the FLIRC for that. You may have to enable the rc6-mce-lircd remote in MyOSMC as well if it doesn’t do that on its own. If you have to tweak any keys after that I personally would probably just use keymap editor instead of tweaking the FLIRC.

HOW is that done? Is there a Keymap editor app or do I edit some settings file? In that case, which one?
Appreciate your comments!

It is a plugin that you can get from the Kodi repository.

Add-ons / Program add-ons / Keymap Editor

All that it does is modify your normal keymap file (like you would if you were doing it manually) but it is much easier as it will recognize the ir codes without you having to figure that out. This can only happen when the remote is actually sending a signal and that is why I recommended you move your setup to MCE as you said you were still missing keys and most universal remotes I have seen map all the buttons to something if it is set to MCE. If you had the remote set to something else it may not actually map many of the keys to anything which would mean that your FLIRC could never pick those up either. I suggest you set the FLIRC up as MCE as well just to simplify how many pieces your having to play with. If everything is set to MCE you only need to deviate from stock/default with one settings file (if that is even needed) which Keymap Editor will modify very easily.