New OSMC Volume at100% won't change from remote

I have built a new media center using RPi3B+ as the platform and the latest OSMC for Kodi.
Some issues were discussed already in a couple of other threads, where these were solved.

Now I have connected the box by HDMI to a Sony TV at the final location and reconfigured WiFi login so it connects to the network. All seemed to work fine, but as soon as I start playing a video file the audio volume is at max and screams through the room!
When I hit the volume button on my remote there is a pop-up on screen saying:

Volume 100%

No matter how I press the volume down or up it does not change the audio level.
I am using the same remote I have been using for my first OSMC/Kodi system, it works with a USB connected FLIRC adapter. I extracted the adapter and took the remote with me when I traveled to the summer house where it will be over the summer. All other functions on the remote works without problems on both the old OSMC and the new box.
Only on the new OSMC box does the audio refuse to obey the Volume buttons, when the remote is attached to the old OSMC box the volume works as expected (including remembering the level between uses and reboots).

How can I get this working properly?

I have a Logitech K400+ keyboard/mousepad combo attached too, so is there something I can do from that to fix the volume control problem?

I found volume buttons on the keyboard and these do work.
I also found that if I switch off the keyboard (pull the USB transceiver from the RPi) the remote volume button works differently so the minus button actually increases volume and the plus button does nothing.

You should know by now we will ask for logs.

Of course, kodi volume will have no effect if you are using passthrough.


I thought this would be something along the lines:
Go to Settings/xxx/yyy and configure the button
Edit the .kodi/userdata/xxxx.xml file and add this and that

Is there some settings file that is used to define the remote interaction, which I might have tweaked on the old system (like 3-4 years back)? In that case I might need to get a copy of it from the old OSMC.

What do you mean by “passthrough”?

I have an old Motorola TV-box remote which I configured for Kodi years ago via FLIRC. It has been working fine ever since.

Now I moved the USB connected FLIRC receiver from OSMC #1 to #2 and it seemed to work. But I could not test audio when in my office since the HDMI was connected to my PC monitor only.
Now on location I connected HDMI to the SONY BRAVIA TV here and found out about the audio. I have had the other media center out here and working fine last year the whole summer…

The volume is stuck at 100% if you have passthrough enabled, which I suspect you do.
We can only change the volume on PCM, or it wouldn’t really be passthrough.

Passthrough means that under Settings -> Audio you’ve enabled Dolby Digital and DTS bitstreaming etc. If you are confused, upload a log via My OSMC.

In which case you can only adjust volume if using CEC compliant device.



I checked the Audio settings and passthrough was NOT enabled.
So then I enabled debug logging, restarted the system and then opened a kids video file. When it played I tried to change the volume but nothing happened (and now the pop-up info about 100% volume was not shown).
I tried both up and down volume to no effect.
Next I quit the video and went to MyOsmc and uploaded the log (selecting all logs).

During the tests the Logitech keyboard combo was removed, only using the remote control via the FLIRC USB interface.

Suggest to try to change via an App (Yatse) or the webinterface. That will tell you if it is a volume problem or a keyboard issue

Yatse works fine to control volume, as does the Logitech combo keyboard when it is connected.
But we want to use the dedicated remote to make things workable for the kids and not clutter the table too much. It is so strange that two instances of OSMC work in different ways like this using the exact same remote hardware…
The working player is running OSMC on RPi2B since a few years back (when it switched from raspbmc) and was upgraded to the latest version just a short time ago. Volume still works as does all other tested remote functions.
The new player is a new install from last week on new RPi3B+ hardware. It seems to work ok except for remote volume control. Jump buttons (red/green) als work fine.

So I understand this is the remote you want to get working on RPi#2.

Have a look at the settings on RPi#1 and repeat them on RPi#2. See Configuring a remote

Probably copy remote.xml from RPi#1 to RPi#2 (if it exists).

I cannot find a remote.xml on the old OSMC box, only a py file:

osmc@rpi2-osmc:~/.kodi$ find ./ -name "remote*"

Searching for something related to key:

osmc@rpi2-osmc:~/.kodi$ find ./ -name "key*"

But keyboard.xml does not containg much:


Then I can’t see any shortcut solution. You are just going to have to go through the procedure you did to make it work with RPi#1.

If only I had made notes at the time… It must be 3-4 years ago; in fact I downloaded the FLIRC config utility in July 2015…

I am now making notes of many similar things, but then one has to have an archiving system to find it later on…

Did you even consider checking your forum history here?


Why are using the pi to control the volume in the first place? Is there some reason why you don’t have your remote/flirc programed to control the volume on the TV instead?

I don’t understand your question…
The RPi runs OSMC - Kodi and it has a media disk of 500 GB where the videos to watch are stored. When I switch my TV from its usual connection to the HDMI from the RPi, then all actions are controlled by the Kodi-remote and I don’t see why I should grab the TV remote in order to adjust the level of the playing video in Kodi, when there is a Kodi specific level control which should be the natural use.
The sources connected to this TV may have rather different audio levels and if using the TV remote for volume large shifts will happen when changing HDMI input…
And the Kodi remote runs all visible actions when Kodi is on the screen…

I guess @darwindesign suggested to take the path of least resistance so you could have fun enjoying the summer but have fun trying to figure out why a volume button on the pi remote doesn’t work properly I guess

Not really. My account was lost due to timeout when they revamped the site a year or so ago and I created a new login. So I guess my history is lost too.
How do I check? Via “My Account” or something else?

The account you are using was created 4 years ago and has created 169 posts.

On the top right of the page, click on the 3 bars to see the menu.

All of your post history has been retained.

Perhaps I needed to elaborate. The way most people with a simple setup such as yours control their volume is by adjusting it at their TV. Their Kodi box is treated no differently than a DVD player (ie fixed output with no volume control) so the volume buttons on their remote are setup to push that duty to their TV. There should be no reason why a second remote should be needed. It just seemed like you may have been making things more complicated than they needed to be.

The TV remote is missing such important buttons as Play, FF, RW, PAUSE, STOP. So only using a TV remote makes it impossible to actually select and start a video, pause it and fast forward and reverse.
So why should I not use a remote with all these buttons related to playing a video?
And then comes the problem I am having that can be “solved” by using TWO remotes where the volume is on one and everything else on the other. Is not that to complicate things?

Meanwhile I have tried to reprogram the FLIRC unit using the Kodi template built into its config utility. Turns out that I am getting the same dismal functionality with nothing happening on +Volume and -Volume making the volume INCREASE.
To me it looks like the FLIRC config utility has a bad Kodi definition for the keyboard commands. It is late now so I have to postpone further tests until tomorrow.