New purchase first use osmc remote has no effect

I did remove the plastic tab from battery, the blue light comes on when buttons pushed.
I’ve searched for tutorials to no avail. Is it me not doing something correctly. I expected the remote to function without any setting up? I can use my mouse and keyboard. I’ve also tried plugging in the IR , still no go.

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

I’m jumping into the OSMC experience ice cold, after my teething time was finished with an X92 kodi box. I just looked up the remote at osmc’s store and the problem is the receiver for the remote was not included with my order.
I’ll contact OSMC
Thanks much for the input

The remotes are machine weighed, and cannot be packed without a dongle.

Please check the packaging thoroughly. It’s on the outside of the wrapper. Occasionally people miss this when opening it.


Fortunately the customer found the dongle!

He is also having fun! Thanks Sam for your help!

No matter how high up the ladder …one is usually humbled by the most simple mistake.

I’m still chuckling over me.

On another note Sam The post office gave the box a stress test by crushing one of the top sides in.

I was nervous opening the box until I saw how well you anticipated the rough handling. :slight_smile: The inside Vero 4k box as well as the Vero were in a pristine condition. Kudos

1 Like

We are aware of how delivery companies treat parcels, so the outer box is effectively offered as a sacrifice.

You can kick them, stand on them or throw them and the contents will be fine!

Let us know if we can help with anything



arf I’ll have to test that on my next Vero4k order :smiley: :joy::rofl: