New remote issues since may update

Hi. Since the April my cec remote has been working, I am using a Samsung TV. Now, since the may update I am having new issues. I think it’s because the vero2 is picking up the remote through CEC and the lirc file for Samsung, I’m experiencing double taps a lot. I have tried everything I can think of - disabling CEC in the settings, trying to disable the Lirc file in the osmc’ settings. The only thing that works slightly is disabling CEC, however, the problem I have with the Lirc method is vero2 is responding to remote key presses when I am watching another source (eg normal TV) so when I switch back to vero2 I find I am on a different menu or have shut down etc. I think I need to disable the Lirc file but can’t figure out how to do if - selecting “doable rc6” doesn’t seem to do anything.

Any suggestions? Thanks

I think I’ve managed a hack-fix. I ssh’d in and renamed the relevant Samsung lirc Conf file to .disable.

If you don’t configure a Samsung remote via My OSMC -> Remotes, you won’t get double presses.


I have the osmc remote which has been working a dream until this update where it no longer works at all, the settings in the remote section are set as they were to the correct remote (osmc) and I cant see any other issues that could affect this change. Any help would be appreciated as the android app is a little temperamental on my phone and would love to get back to using the remote.

Rear USB has been changed to provide full speed in the May update. Try plugging the remote dongle into the rear USB and reboot. Report back here with your subsequent findings please.

That solved the issue Thanks very much!

Hi George,

Some background:

Some users have reported an issue where the remote goes crazy. The symptom is that sometimes the remote repeatedly presses the last button you pressed until you press another button.

This is caused by the USB driver that Vero 2 uses. We use the Synopsis DWC OTG driver. This is a less than stellar driver. It expects real time servicing of interrupts on the ARM side, which cannot always be guaranteed. When we get Split Transactions in High Speed mode, they can be dropped if the ARM doesn’t handle the IRQ quickly enough. The end result: sticky remote buttons / repeat presses.

We’re working on porting the FIQ work by jdb and gsh to Vero 2. In the interim, we’ve dropped the rear port in to Full Speed, which doesn’t use Split Transactions, and advise you relocate the receiver to this port in the interim. Split Transactions are used to guarantee that USB Hi-Speed devices remain in Hi-Speed without a drop in throughput when Full Speed devices are used on the same bus. The rear port runs on a separate bus, so we can safely drop it down to Full Speed and avoid issues. This should rid the issue of unwanted presses for now until we can deploy a better solution in the future.



1 Like

Did something changed with the latest video fixes on the USB side?

My vero2 is up-to-date + vero2-mediacenter-osmc 16.1.0-8, the remote dongle is in the rear port, and I’ve seen it happening again. PlayPause was ‘stuck’ while playing with the subtitle offset ‘widget’ and with the OK button (to which I’ve remapped the PlayPause function).

Last time it happened was about 2-3 weeks ago.

No – we have just been changing Kodi. There haven’t been any kernel changes that have been pushed yet.

I’ll see if I can replicate it.

You’ve already told me that you tried without success, and I didn’t say that I can reproduce it. Just that it happend in that context.

When I’ve received the Vero2, it was the first time I’ve played with Kodi, and I’ve used the remote a lot, a few days (plugins, themes, media scrappers, etc.). That time I did stumbled upon this issue frequently.

Let me know if it flares up again. I can think of some ways to improve the remote responsiveness, so I will try them.