New Router (Fritzbox) - NFS Problem

Dear Community,

Im aware this might not be a OSMC specific problem and that there is a similar thread around, I still try my luck here and see if anyone can help me out. I’ve had to change my router (due to a move) and now my former set up is not working smoothly anymore.

My Setup (all via LAN cable):
My Vero4k and my Synology DS215j are connected to a gigabit Switch. The switch then has a connection to the Fritzbox Router. Vero and Synology both have static IP and Router handles the DNS.

On the Synology I am hosting all my media, so with my previous router I had a setup where I added the video sources via NFS, which really worked well after doing all the configurations necessary. However with the new router something is off.

First of all the synology has a new IP so I figured best would be to just add the folders with the new IP, but now if I try to browse via NFS it takes ages - most of the time even the Vero stops reacting for around 3-4 minutes (or not at all anymore). I have checked everything that came to my mind, I can ping all the different clients and I get 0% loss, there is no WiFi involved, as said the synology and vero are connected to the same switch… so I have really no clue what to do more. I even tried via ssh to ping the synology from the vero and it also worked like a charm. Is there something that I am missing? My pc can access the folder on the synology easily and with my old router it always worked out…

So if anyone has some tips that could help me I would be very thankful.

Logs where are I tried to brows around in the NFS screen in Kodi


It looks like it’s still trying the old IP first off:

2020-08-27 22:40:20.787 T:3893359328 WARNING: Process directory 'nfs://' does not exist - skipping scan.

And that you didn’t set a source for the new IP:

2020-08-27 22:41:05.874 T:3631821536   DEBUG: CUtil::GetMatchingSource: no matching source found for [nfs://]

You may try using path substitution so you don’t have to rescan the library, or if you don’t care about watched status you could just create a new library.

Hey, thanks for the reply!

first I tried to just go to the lirbary settings and just change the IP for sources, since the credentials etc didnt change. At this point I have no problem creating a new library, its just that now its exremly slow and it will take me 10-15 min just to add the source, which wasnt the case with the old router

any ideas?

Well, than have a look here

The problem is that you modified your source instead of removing it before creating a new one purging your old info in the process. The source folders are used for scraping only. Once you have added items to your library they are stored as complete paths and any changes to your sources are not propagated to existing library items. The point is moot now but if changing your subnet and using the old IP address for your NAS was not an option the only correct way to deal with this is to ether dump your Library’s or use path substitution to redirect to the new IP address. As you now likely have the same content being pointed to from two addresses using substitution will lead to duplicates and ongoing issues. I would highly recommend starting with a new library as JimKnopf pointed to. I would just add to that post that if your going to delete the databases he pointed to you should also remove the texturecache13 db and the entire /.kodi/userdata/thumbnails/ folder as well.


suprisingly just deleting the library worked like magic, thanks for your support guys