New TV, no signal until hard reboot

So I got a new TV (4K Sony) and started getting this weird issue after a few days of use. First everything was fine, but now the Vero 4K+ won’t send a signal unless I cut the power and turn it back on.
Unplugging and replugging the HDMI cable doesn’t work. Already turned off all Link operations on the TV side, disabled CEC, enabled and disabled HPD Lock on the Vero, but there must still be something else.

Have you tried another HDMI cable?

Suggest to provide some logs.

Are there any drives connected to the Vero? Is the red cross on the Vero turning on?

Yeah, tried different cables. I’ll try to get the logs when I get home tonight.

Yes, the same HDD is connected as before. It comes on with the Vero and the red cross comes on, then turns off like normal, so the Vero is definitely on, just no signal.

Is the drive self powered, or is the Vero powering it? If the Vero is powering it then it’s probably the drive causing the issue. You will need a powered USB hub for the drive as the Vero is not designed to handle powering USB drives.

It’s self powered. Never had problems with the drive.

Then we need to see logs to help find the problem.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot: