New update error with base-files (8+deb8u2)

So my last update issue was fixed by the latest update, but a new error appeared stating an error occurred with base-files (8+deb8u2)

I attempted to run the update manually again on my RPI 2, but I get the same issue.

Here are my logs: irimelifex

Thank you as always.

Input/output errors…
Filesystem corrupt? Is there still space on your card?

Well that’s the only error I’m getting. Not sure if it has something to do with file system corruption and as for space as per System info/Storage:

Filesystem      Size    Used    Avail    Use%    Mounted on
/dev/root        29G    2.0G      26G      7%
/dev/mmcblk0p1  240m     39m     201m     17%         /boot

You’ve got major file system corruption there:

Unpacking armv7-remote-osmc (1.1.6) over (1.1.5) ...
dpkg: error processing archive /var/cache/apt/archives/armv7-remote-osmc_1.1.6_armhf.deb (--unpack):
 unable to stat `./etc/lirc/samsung-lircd.png' (which I was about to install): Input/output error
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Also look at the contents of your lircd.conf file in your log file - it’s just full of random garbage.

I would enable fsck on your system and reboot to see if it will automatically fix the corruption. Edit /etc/fstab - on the line which begins like this:

/dev/mmcblk0p2  /    ext4

Change the last 0 to a 1, save and reboot. You may need a keyboard attached to answer any repair questions it asks.

As for why corruption is happening - do you unplug the power without shutting down ?

1 Like

Thanks for the reply DB.

Previously, I had my Pi powered by a dual USB cable that attaches to my TV and I was not powering down the Pi manually at all times. (I have everything setup with a Logitech remote and at times I would forget to power off the Pi first then user the power down all option on my remote)

I have switched to a Samsung 1.8A power adapter which now leaves my Pi on at all times.

As for enabling fsck, I reboot my Pi and get a scrolling list of items and then I get to a prompt that asks for a root password for maintenance or type Control-D to continue. I press Control-D, put in the username and password which brings me to a prompt to enter commands.

Should I be trying to run the fsck command there or should it have done it automatically on reboot? Any other suggestions for commands to run is appreciated.

Hard to know what is happening without a screen shot showing the exact wording.

Sorry about that. Here’s a screenshot:

Pop your SD card into a PC - edit the file called cmdline.txt, at the end of the same line add a space then:

Save then try booting again.

In theory this should force it to run automatically. If not please take another screenshot of the error you get.

1 Like

I think that fixed it! The message went by too quickly, but went to a black screen and ended going back to my usual OSMC start screen.

I was then able to run the update.

Thanks again DB!

Thanks for that - the option that you added to cmdline tells fsck to automatically choose yes to all the repair options that it would have otherwise prompted you for - this allowed it to run automatically to completion.

We are working on changes to the way fsck runs on boot, and also are working on changing the emergency mode so that it is usable - at the moment you can’t log in because there isn’t a root password, but we have found a simple way to bypass this, making the emergency console usable. Hopefully this will be ready in time for the next monthly update.

1 Like