New Vero 4k+ - Can't Play Media from External Hard Drive

I recently bought a Vero 4K+ and everything works better than anything else I’ve tried Kodi on except for playing local files from an external hard drive (Seagate 4TB HDD - Formatted NTFS).

  • Drive auto mounts just fine and can be easily navigated
  • Scanning files to media library is extremely slow (slower than on other devices) and sometimes pauses all together
  • Playing files, either scanned to the media library or from the file manager, both TV Show Episodes and Movies, is really inconsistent and always has issues

Noticed Variants of Behaviour:

  1. Click video → Wheel Spins for ~90 seconds → Video loads and plays just fine
  2. Click video → Wheel Spins for ~90 seconds → Video loads and plays but freezes after 3 seconds
  3. Click video → Wheel Spins for ~90 seconds → Video loads and plays but terminates after 3 seconds
  4. Click video → Wheel Spins for ~90 seconds → Nothing happens and I go to back to browsing media like normal
  5. Click video → Wheel Spins for 5+ minutes until I get impatient and reset the device

Note that all other media played from add-ons like YouTube and Twitch load in under 3 seconds and play without issue. I’ve tried this drive with Kodi on Xbox, Raspberry Pi 3, and Laptop and files play instantly without issue on all three. I’ve tried another Seagate 4TB HDD playing the same media but formatted as EXT4 - issues persist. Tried changing display to various resolution and frame rates- issues persist.


Wheel Spins for ~90 seconds and then nothing happens:
2021-06-05 22:42:25.120 T:4069280960 DEBUG: OnPlayMedia /media/Seagate Portable Drive/Multimedia/Videos/Movies/The Girl Who Leapt Through Time (2006).mkv

2021-06-05 22:57:20.425 T:4069280960 DEBUG: CPlayerCoreFactory::GetPlayers(/media/Seagate Portable Drive/Multimedia/Videos/Movies/Snowden (2016).mkv)

2021-06-05 23:07:15.065 T:4069280960 DEBUG: CPlayerCoreFactory::GetPlayers(/media/Seagate Portable Drive/Multimedia/Videos/Movies/Zombieland - Double Tap (2019).mp4)

Wheel Spins for ~90 seconds, content loads and plays, freezes after 3 seconds and then terminates when I try to seek:
2021-06-06 09:17:57.608 T:4064750784 DEBUG: CPlayerCoreFactory::GetPlayers(/media/Seagate Portable Drive/Multimedia/Videos/Movies/5 Centimeters Per Second (2007).mkv)

Is the drive externally powered?

No it’s not. I’m just plugging it in directly to the Vero via USB.

That’s almost certainly your issue. It will need to be externally powered or you will need to use a powered USB hub.

Hi Sam,

Thanks for the quick response. I was able to solve this issue by connecting the drive to an externally powered USB hub as you suggested.

However, I was reading other threads regarding power issues and I really hope you consider making an updated Vero model with a larger power supply and USB 3.0 ports. It’s a fantastic device otherwise.


You’re welcome.

Your feedback is noted :slight_smile:

We are always improving our products, but don’t have any news at this time.