New Vero 4k +: Help with Atmos

Ordered mine on June 25th, got mine today!. Thanks for your hard work Sam. Just playing around with it now. I have a problem, I can’t get it to play atmos tracks, I’m playing files from a hdd. I’ve got pass through allowed, sync playback to display is off. I read that turning on display refresh rate helps but then my tv loses signal. I have a LG oled c7. If someone could point me in the right direction that would be appreciated. Cheers, I’m new to all this.

I put this in a new topic, as it had nothing to do with the 4k + shipping topic.

Please post mediainfo for the file in question, and logs.

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC.

You can also create the mediainfo-output of the affected media file on the OSMC device:

  1. login via SSH, user osmc, password osmc
  2. if not already installed: sudo apt-get update && sudo apt-get install mediainfo
  3. cdto the directory containing the video/audio material in question
  4. mediainfo -f "<media file>"|paste-log, where <media file> is your video/audio
  5. publish the returned URL here in this topic

Thx for your help.To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Hi Matt

Glad to hear you’ve received your device!

Can you let us know if you have an AVR receiver?
Can you show us a quick screenshot of your audio settings? Make sure you’re in expert mode and have enabled support for all passthrough formats if supported.

When you say Atmos doesn’t work: can you clarify if you hear anything, and if it’s just a case of not seeing the Atmos passthrough sign?



I’ve sorted it now, didn’t know about expert mode, enabled all supported passthroughs now.
Thanks for your help Sam.

No problem. It’s commonly overlooked. The good news is that it’s an easy one to resolve :slight_smile:

Let us know if you have any other questions, otherwise enjoy!