New Vero 4k+ keeps crashing

Received my Vero last week and initially worked great, very impressed that I had hd audio pass through at last.
I use it connected to a 2tb Samsung hdd, hdmi to my Denon 2400 receiver, then on to my Samsung KS7000 4k tv. Like I say, all good, until last night. I had disconnected the hdd to add some media from my laptop and when I reconnected, it started acting up. As soon as I select a film (that played previously) the picture goes and sound stutters - everytime. I press stop but the picture is still gone, only option is to pull the plug. Doesn’t always reboot either, seems to be better without the hdd attached at that point. I’ve tried a different usb stick - same result. Also tried a different high speed hdmi cable but nothing changes.

Here’s the log from earlier this morning.

I’ve also tried connecting the vero direct to monitor at my work and I get the exact same result.

Hi Steve,

I believe you got in touch with our Facebook page, but the messages don’t seem to be going through very well.

Can you let me know if the 2TB Samsung drive is externally powered? This may be an issue here.

I can see you try and play Mission Impossible. Is this the film that stutters? How is your hard drie formatted?


Yes the drive is externally powered and it formatted in NTFS. Drive was working fine with the Vero for 4 days prior.

Now I’m home I’m trying again with it. It seems like the hdmi signal is broken as the picture rarely comes on, when it does it’s very snowy. I’m trying to upload another log but the picture isn’t on the screen long enough. The hdd isn’t connected either at the moment.

Thanks for confirming the drive is externally powered.
Are you playing the same content as you were before? Could you try with something that you know worked before?

Where possible – we suggest avoiding NTFS; as it can lead to some performance issues. But if you’re playing the same content as before, and it’s now problematic, then that’s likely not going to be the issue.

From your logs, I have a couple of suggestions:

  • Can you make sure you set the GUI to 1080p? You can do this under Settings -> Display. As you have Adjust Refresh Rate, we’ll automatically switch to 4K when you play 4K content. This is the recommended approach.

  • If that’s not helping, I suggest trying another HDMI cable.


Picture goes as soon as I go into the sub menus. Tried 3 hdmi cables and nothing changes.

Hopefully you can see the snowy picture
Got another log uploaded

When I go to My OSMC I get a normal picture

Did you change the resolution default as advised?

Can you let us know if you experience this problem with the HDMI connected directly to TV? Usually the ‘snowy’ effect means there’s a dodgy cable in the chain (I see you’re connected to an AVR).

We should be able to get this resolved for you promptly with a bit more info.



Yes resolution has been changed. The snowy effect was also present when I connected it up to a monitor at work, with a completely different hdmi cable. I think it’s the hdmi socket on the Vero.

Sorry to hear this.
I’ve pinged you some return instructions.