New Vero 4K not opening mkv after enabling inputstream.adaptive

So the Vero 4k worked great out of the box. Then i decided to install iPlayer WWW and somehow managed to work out the installation of the inputstream.adaptive addon.

However, after this was done, I now can’t open any 720p .mkv file. Any pointers? I’m almost at the stage of returning for a refund.

So i’ve managed disable inputstream.adaptive and rebooted the Vero 4k. Now .mkv files are working fine, but I can’t play iPlayer now. Is it at all possible to have both working?

We need logs which demonstrate both issues.

Should have been included by default, just needs enabling.

Provide us with a debug log, we’ll get it fixed if it’s an OSMC issue. You remark that the Vero 4K works great out of the box. If it’s a problem with iPlayer, it’s up to the maintainer to fix this issue.

Also make sure you’re not using a VPN or anything. iPlayer will only work properly if you are resident in UK. They have been cracking down on VPNs lately.

Apologies for the lack of clarity in the original comment. I will get logs and upload them here shortly. The sole problem i’m having is the failure to play any kind of .mkv file now.

To summarise:

  1. When i received the Vero 4k, I turned it on, opened a few .mkv files and all was great.
  2. After watching a few mkv files from a local USB drive, I decided to watch iplayer (no VPN). To do so, I had to go to the add-ons section and tried to install iPlayer-www. However, I had to enable input adaptive stream (error message on install was that adaptive stream was not enabled).
  3. After enabling adaptive stream and successfully downloading iPlayer-www, i watched some bbc junk before deciding I wanted to watch another .mkv file from a local usb file
  4. The .mkv file failed to open
  5. I tried to open one of the previously played .mkv files but no joy

So right now, I have a pretty brick sat under my tv. Again, I’ll be providing logs shortly, but would still like to know about your returns/refunds policy.



Sorry to hear that your device is working as expected.

We can’t support iPlayer internationally, and you haven’t let us know if you’re trying to watch this outside of the UK.

If you’ve installed software on your system, it’s possible this is causing problems and preventing your files from playing. I checked your logs, and they do not show much, but you seem to be trying to play a file from an external USB drive.

Have you tried local playback, for example from the eMMC?

The error you receive is actually atypical when the hard disk is not being powered correctly or there are incorrect permissions preventing access to the drive. Without knowing what changes have been made on your device, it’s hard to speculate what the issue is specifically.

The good news is that it’s very easy to reinstall OSMC and you can be up and running again in a few minutes.

Our returns policy is pretty standard, and follows EU and UK guidance. We haven’t had any returns of Vero 4K to date though, and I’d be far more interested in making this thing work for you.

Hi Sam, I can confirm I am watching iPlayer from within the UK. I haven’t installed anything else on the device other than the iplayer-www addon. I’m going to re-install OSMC as per the instructions.

Great – let me know how you get on.