New Vero 4K not seeing network devices

Brand new today and I’m having installation issues.
Firstly, I have never used Linux, and for that matter don’t believe I need to!
I bought this box to replace my older system that worked great for playing HD movies, but not for my new 4K TV. Basically I had the following all on a CAT6 wired network (I don’t do WiFi!):
Serviio on PC feeding 8 way ethernet server in lounge to:
WDTV LIve Streaming box
SONY TV (as well a some other ethernet devices that don’t form part of this stream).

I have now updated to a Panasonic 4K TV and needed to update the WDTV Live box to something that could handle 4K movies with HDR, HDR+, Dolby Vision and up to True-HD Atmos sound.
Searching websites and forums I chose the Vero 4K as it appeared to do everything I wanted from a streamer with movies for my new TV and all in a neat case too!

I have managed to setup everything and the network works with a fixed IP address (lots of equipment, so I like to have control over addresses, plus I can debug better when I know the equipment addresses. As I have updated the box I know the network is working.

The problem I have is not being able to see Serviio. The TV is listed and as this is on the same network, so I would have thought Serviio would be listed too. As a check, my TV and BD Player see and play Serviio files (but not to full spec.).

So how do I go about getting the box to see all the devices on the network?

I have setup the SMB client, UPnP/DLNA and have also tried directly accessing the files from the Video scrolling option. To be fair I don’t really know what to enter here, as it may be linux. I have a drive named ‘TV’ and tried browsing to this but it just shows ‘path not found or invalid’.

I have also changed the TV drive to shared which hasn’t helped either.

So, can anyone throw some light on this for me please?

So all your files are on the Serviio? Does it allow access via SMB or NFS to the raw filesystem, or does it only support access via uPNP/DLNA?

Although you will get a much better experience by using normal file shares and scanning your media into a Kodi library, if you want to use UPnP you would go to Videos>Files>Add Videos…>Browse>UPnP Devices> and your serviio server should be listed there. Select it and hit OK, then OK again on the next screen. At this point you should have an entry in the Video>Files section that allows you to access your media.

If your using the classic/Estuary skin this is the only place your can access your UPnP server from. If your using the OSMC skin you will have to manually edit the menu options to fit what you want. An example of how you would go about doing this would be to go to settings>interface>skin>configure skin>general>customize home menu>Movies>choose item for menu>videos>sources>[UPnP server name]>[path to content you want such as video library>movies]>create menu item here. Repeat for each menu you want to create

Thanks for the response.
I would just like to say that comments such as “you will get a much better experience by using normal file shares and scanning your media into a Kodi library” are relatively pointless. Sorry, but you assume the user has a knowledge of this operating system. So how would I go about this?
Can you point me to a website that might just give me a clue?
I entered UpnP Devices and it reported it could not find any. The network wasn’t connecting. (but the network is connected, as reported earlier) Do I want to go ahead anyway? I selected Y. Now reports this directory contains… none.
As a test I removed the HDMI and ethernet cables and plugged them back into my WDTV Live and hey presto Serviio. So the network is clearly working and connected.
So what now?

I agree this might be a bit confusing at first, but OSMC is build around Kodi as a full fleshed Mediacenter/Server. So it is kind of designed to replace your Serviio.
Normally people use the Vero together with a NAS and let the Vero handle all the Media Management. If you want to go down that path then check out this link

But using Vero as a UPNP Client should also be working (see and

As far as I’m aware Serviio just installs and runs, no other SMB or NAS settings required.
I tried these settings just in case though, but no luck seeing my PC shred folders: aniother crowse type entry that I don’t know about perhaps?
I already use SMB for linking my tablet. NAS however just gives me an error which appears to be yet another Windows problem that requires a complete install (doesn’t everything in Windows), so I’ll leave that for now.
I still want Serviio as my TV and BD player use it seamlessly; however, if you feel I would be better off scrapping it for this box’s better functions, who am I to argue.
As an aside, I understood this box wouldn’t be a plug and play type, I just didn’t think it would be so troublesome to get basic functionality working. I think I need to read up more about Kodi etc.

The links are an excellent introduction, thank you.

The method you have been using to share video is called UPnP. The way that works is that your server (in your case serviio running on Windows) contains not only access to your media files, but also all media information for them. When you connect to this with a UPnP client (TV, WDTV, tablet, etc.) the client just sends requests for information back to the server and then displays what comes back. This can make for an easy way to share media across devices as you are aware.

Kodi, the media player that runs on OSMC has the ability to act as a UPnP client. This UPnP feature is not something that has been fully integrated into Kodi though so compared to a standard way of running Kodi, (which is where all the media information is stored in Kodi and files are accessed directly) will normally produce less media information, slower browsing, and limit which Kodi features are available. With that being said there is others that run Kodi this way and are perfectly happy with it. My “relatively pointless” comment was meant to temper expectations and encourage further research into how Kodi works, without assuming what you do or do not know.

The first thing you should probably do is first go into settings>system information>summary and make sure your Vero has a valid ip address showing.

The screengrabs below illustrate what i’m talking about. With a UPnP connection to Serviio (which I installed ten minutes ago and my device connected to without issue) there is no movie set groupings, no fanart, no media info aside from length, and the resolution of the movie poster is very poor (other titles were much worse and suffered from aspect ratio issues). This might not be a dealbreaker for some, but it is worth pointing out IMO.

1 Like

I am not sure what would be shown on the screen if the IP address were wrong, but the manual setting is not in contention with any other devices. ipconfig /all in windows shows this to be true. It should also be noted that Serviio also recognises all networked devices by IP and those that are active. It shows the box name as Kodi and that it is active, so there must be some communication going on between the Vero box and my pc.

Your image makes a very strong point regarding the capabilities of Serviio and the Vero box. My other devices break down the videos into folders for genre and doesn’t just list them all.
So, assuming I wanted to share my folders using SMB through Vero, what would I need to input into my browse settings, bearing in mind that this needs to be entered as text, and is not searchable as shown in the Kodi links.

If Serviio is seeing the Vero then I would assume the ip address is okay and that multicast is not being blocked. In this case I would dig into your serviio settings to make sure you don’t have it being blocked there with one of its user or device permission settings.

As for browsing the media selection (genre etc.) are available with both a Kodi Library or UPnP.

If your going to go the smb and normal Kodi library route you will first have to setup your Windows machine so your media files are shared. Once you do that there is several ways to add this into Kodi. The information you need should be found in either the links fzinken and ActionA posted above. Further information can be found here…

It is not just Serviio that sees the Vero 4k box, I was just using this an an example. Everything else on my network sees it too. So why can’t the Vero find anything on the network?

Please provide us with full debug logs. Without debug logs, we’re just randomly guessing.

You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

How exactly do I reproduce the issue of the Vero not being able to view any other device on the network?
If I run it then create a debug log, will this show that other devices are connectable? Will it show their addresses and shared folder content?
I asked how to set the box up to view external devices. I am still waiting for a response.
By making the browse function text only and not a searchable interface I need to know exactly what to type into the browse field.
My router ethernet IP address is This is clearly working, as I have updated via the web.
My pc IP address is
Both IP addresses are manually set eg fixed.
Shared folders on the pc would be C:\Shared or T:\ etc. So what do I need to enter in the browse field to gain access to this material?

It should show us how you’ve tried to add the sources, as well as any connection errors when trying to connect.

Assuming this is on a Windows PC, if you right click on the folder and click Properties and go to the Sharing tab, it should tell you the Share name. We can then help you construct the path to put in to the sources box.

Thanks, but having spent a week just to get this far is nothing more than a waste of my time and money.
Instead of getting me to send debugs, wouldn’t it be more prudent to provide information as to what I need to enter rather than let me keep having to guess!? Either others have managed to guess right or the box just doesn’t work.
As it is seemingly impossible to get basic support for this product it remains not fit for purpose and I have arranged to return it and get my money back, I shall then purchase something of marketable quality.

There is a guide on how to connect to shares here: File sharing with a NAS, media server, windows share or other device

To do that, we need to know the names of the shares, and we have told you how to find these names under what we assume is a Windows PC.

You do realise that the Vero is considered to be one the easiest, if not the easiest to use Kodi systems. We also try and provide the best support and we were/are more than happy to help get you up and running. I suspect you may encounter issues with other devices as well.

Good luck,


You won’t find a single device anywhere in the world with such good and comprehensive support as the Vero. If you can’t provide information requested then how can you expect people to help you?

Your responses are unhelpful and suggest you are hiding your true usage of this great device.

Sam and others have offered a lot of support and guidance and your frustration does not help yourself or anyone else in a similar position.

We all started at the beginning with little knowledge, but thanks to this forum many of us now have a fantastic little movie and music player.


It would be such a shame to give up. Ive just got a Vero4k+ and love it. Once you figure out how to share files from your Windows PC without Servio, you’ll find it really easy.

Try this -
On the Vero go to
Settings/Media/Library/Videos/Add Videos
Choose Browse then Add Network location
Protocol - Windows Network (SMB)
Under Server name type -, then click OK
Back in the Browse for network share select smb://
Any SMB shares you have should show up here.
(If its empty, then you may not have any folders shared on your PC. As Sam says, if you right click on C:\Shared on your Windows box and choose Properties/Sharing you should be able to see the share name if its there.)

Select the share then hit OK a few times and you should be able to set the content type, video/TV/Music, etc
Once you’ve done that it should start reading your media and add it to the kodi library.

P.S. I suspect the reason you dont see your SMB shares by browsing is because of this -
From -

" Note: Network browsing is no longer possible with Samba v2 and upwards. Samba v1 was deprecated May 2018. To add Network Sources, see Section 6- Adding Remote Sources below"

That is why you have to add a network location manually as I described.